tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From matthew denner <matthew_den...@wamnet.co.uk>
Subject Re: tomcat 3.1 doesn't work on redhat linux?
Date Wed, 19 Apr 2000 21:38:58 GMT
matthew denner wrote:
> 
> Guido Medina wrote:
> >
> > set $JAVA_HOME=/path/to/jdk1.2.2
> > set PATH="$PATH:/bin:/usr/....:$JAVA_HOME/bin:$JAVA_HOME/lib...."
> 
> i have tried this and it doesn't solve the problem.  the problem seems
> to be that although the xml.jar file is in the classpath generated by
> startup.sh (or tomcat.sh) and it contains the right classes, that
> com.sun.xml.parser.Parser can't be found.  i don't think it's anything
> to do with paths or java directories as i've set:
> 
> TOMCAT_HOME=/home/mdenner/temp/jakarta-tomcat
> JAVA_HOME=/usr/local/java
> CLASSPATH=
> PATH=$PATH:/usr/local/java/bin:/home/mdenner/temp/jakarta-tomcat/bin
> 
> i've even made sure that the xml.jar file is in the classpath by setting
> CLASSPATH=$TOMCAT_HOME/lib/xml.jar before running startup.sh.

i've created a java class that extends com.sun.xml.parser.Parser and
it works fine with the classpath set to include $TOMCAT_HOME/lib/xml.jar
so i'm a little confused!

=======================================================================
Matt Denner                       Senior Software Engineer @ WAM!NET UK
                                                        +44 1202 208571
-----------------------------------------------------------------------

Mime
View raw message