tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gtallen <gtal...@home.com>
Subject Re: Tomcat won't start - Exception in thread "main"java.lang.NoClassDefFoundError: org/apache/tomcat/startup/Tomcat
Date Wed, 05 Apr 2000 05:38:28 GMT
Are you sure your picking up the right jvm.  I thought Redhat
installs another jdk too (#which java).  Just a thought!

Greg

David Stack wrote:
> 
> Hello,
> 
> I am trying to get Tomcat v3.1_beta_1 started on Linux Red Hat 6.0.
> I have java version "1.2.2" installed also.
> 
> When I run 'startup.sh' or 'tomcat.sh start' I get the following error:
> 
> >> root /usr/local/tomcat/bin>Exception in thread "main" >>
> java.lang.NoClassDefFoundError: org/apache/tomcat/startup/Tomcat
> 
> This is driving me nuts!  So I read some old posts in the mailing list
> archive and they talk about setting the environmental variables might fix
> the problem.
> So I tried that, and it didn't do anything!
> 
> Here is part of my .bash_profile that i tried:
> 
> PATH=$PATH:$HOME/bin
> CLASSPATH=/usr/local/jdk/jre/lib/
> LD_LIBRARY_PATH=/usr/local/jdk/jre/lib/
> TOMCAT_HOME=/usr/local/tomcat
> JAVA_HOME=/usr/local/jdk
> 
> ENV=$HOME/.bashrc
> USERNAME="root"
> 
> export USERNAME ENV PATH CLASSPATH LD_LIBRARY_PATH TOMCAT_HOME JAVA_HOME
> 
> Could someone be so kind as to tell me why I am having an impossible time
> getting Tomcat started?   I am sure it is something very simple that I am
> not doing.
> 
> Thanks you very much!
> 
> Dave
> 
> --------------------------------------------------------------------------
> To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commmands, email: tomcat-user-help@jakarta.apache.org

Mime
View raw message