tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "kenneth.baltz" <kenneth.ba...@inforonics.com>
Subject RE: Problems starting up tomcat on NT
Date Thu, 06 Apr 2000 18:50:30 GMT
I'm fairly new to this installation, but I think Tomcat binds at least two
ports by default, 8007 and 8080.  Is it possible you have something else
running on 8080?

K.C.

> -----Original Message-----
> From: Mark Fleischman [mailto:mark@lacima.com]
> Sent: Thursday, April 06, 2000 2:42 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Problems starting up tomcat on NT
> 
> 
> I am currently getting a:
> 
> java.net.BindException: Address in use
> 
> when starting up tomcat. Has anyone come across this?
> 
> I am fairly sure the port 8007 is not being used by any other 
> service (ran 
> some software to ping the port) . I have even tried with 
> Apache not running 
> though currently it is using port 80 and that should not 
> interfere.  Apache 
> is working fine.
> 
> How can I tell for sure what host  & port tomcat is using - from the 
> tomcat.properties file? It is clear what Apache is expecting 
> but not where 
> Tomcat is picking up this info??? Does the
> tomcat (start) script take some arguments to force these 
> kinds of settings? 
> What else can I check?
> 
> Here is the stack trace:
> 
> FATAL: java.net.BindException: Address in use: bind
> java.net.BindException: Address in use: bind
>          at java.net.PlainSocketImpl.socketBind(Native Method)
>          at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:390)
>          at java.net.ServerSocket.<init>(ServerSocket.java:173)
>          at 
> org.apache.tomcat.net.DefaultServerSocketFactory.createSocket(Default
> ServerSocketFactory.java:103)
>          at 
> org.apache.tomcat.service.SimpleTcpEndpoint.startEndpoint(SimpleTcpEn
> dpoint.java:188)
>          at 
> org.apache.tomcat.service.SimpleTcpConnector.start(SimpleTcpConnector
> .java:140)
>          at 
> org.apache.tomcat.core.ContextManager.start(ContextManager.java, Comp
> iled Code)
>          at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:124)
>          at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:130)
> 
> 
> Here is my setup:
> 
> Windows NT sp 6
> JDK 1.2.2-001
> Apache 1.3.12 for windows
> Latest Tomcat 3.1. beta binaries.
> 
> Thanks in advance for any pointers.
> 
> Mark
> 
> 
> -
> ________________________________________________________________
> Mark Fleischman ~ LaCima, Inc. ~ mark@lacima.com ~ 650/853-8538
> 
> --------------------------------------------------------------
> ------------
> To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commmands, email: tomcat-user-help@jakarta.apache.org
> 

Mime
View raw message