tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Franky Mas de Xaxás <fm...@nexo.es>
Subject Re: Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tomcat/sta
Date Mon, 17 Apr 2000 17:55:03 GMT
Hi Maksym,

thank you very much for your quick response.

Frome your email I realize that the mising class should be inside webserver.jar.
I think I'm using Tomcat (3.1) since I downloaded from http://jakarta.apache.org/builds/tomcat/release/v3.1_beta_1/bin/jakarta_tomcat.zip

Do you know why the class org/apache/tomcat/startup/Tomcat doesn't appear in webserver.jar.

Thank you again.

Franky:  fmasf@nexo.es


  ----- Original Message ----- 
  From: Volkov, Maxim 
  To: 'tomcat-user@jakarta.apache.org' 
  Sent: Monday, April 17, 2000 12:57 PM
  Subject: RE: Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tomcat/sta


  Looks like you are using old Tomcat (3.0), according to your classpath.
  The problem might be that startup/tomcat is provided for new Tomcat 3.1 and its webserver.jar
is located at different path.
  Check your paths
  Good luck!

  Sincerely Yours, 
  Maksym Volkov, 

  Technical Writer, 
  Telesens Ukraine Ltd. 
  phone: +(380 572)190-567 (205) 
  e-mail: M.Volkov@telesens.com.ua 
  www.telesens.com.ua 
  Ideas expressed in this message are my own and not necessarily reflect that of my employer.


    -----Original Message-----
    From: Franky Mas de Xaxas [mailto:fmasf@nexo.es]
    Sent: Monday, April 17, 2000 12:56
    To: tomcat-user@jakarta.apache.org
    Subject: Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tomcat/sta



    Hi,

    Im triying to run Tomcat on Windows 95 but I get one error:

    It seems I don't have the class named org/apache/tomcat/startup/Tomcat, since I get the
error listed below when I try to execute the comand 'tomcat run'
      C:\APPS\jakarta-tomcat\bin>tomcat run
      Using classpath: C:\APPS\JAKART~1\BIN\classes;C:\APPS\JAKART~1\BIN\lib\webserver
      .jar;C:\APPS\JAKART~1\BIN\lib\jasper.jar;C:\APPS\JAKART~1\BIN\lib\xml.jar;C:\APP
      S\JAKART~1\BIN\lib\servlet.jar;C:\jdk1.2.2\lib\tools.jar;C:\APPS\JAKART~1\BIN\cl
      asses;C:\APPS\JAKART~1\BIN\lib\webserver.jar;C:\APPS\JAKART~1\BIN\lib\jasper.jar
      ;C:\APPS\JAKART~1\BIN\lib\xml.jar;C:\APPS\JAKART~1\BIN\lib\servlet.jar;C:\jdk1.2
      .2\lib\tools.jar
      Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tomcat/sta
      rtup/Tomcat

    Maybe I should try to work with the file tomcat.properties?
     
    Any one could help?
     
    Thanks for advanced!
     
    ----------------
    Franky:  fmasf@nexo.es

Mime
View raw message