tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ALEXANDROS KOTSIRAS" <ALEXANDRO...@prodigy.net>
Subject Re: Tomcat installation problem
Date Mon, 24 Apr 2000 02:30:35 GMT
Hello,
Some feedback from my experience also :

I was not able to start Tomcat3.1 with JDK1.2.0 on WinNT.
I was getting the same error message a ...TCPConnector class could not be
found although i "unjared" all the  .jar libraries and placed them in
TOMCAT_HOME\classes folder ,and obviously the CLASSPATH variable was being
set correctly at startup.
Then i decided to install the new JDK 1.3.0rc3  (it's very close to
production version) and everything works fine.
1.3 is not available for UNIX yet.
But Tomcat also works (at least it starts) with JDK1.2.2

Alex.


----- Original Message -----
From: Jonathan Clark <jgc-home@bigfoot.com>
To: 'Sheldon Wosnick' <swosnick@hotmail.com>
Cc: <tomcat-user@jakarta.apache.org>
Sent: Sunday, April 23, 2000 8:22 PM
Subject: RE: Tomcat installation problem


> Sheldon,
>
> Thanks for the tip ... success!  I first tried just doing the
> webserver.jar in the way you describe, and it worked straight
> away. (webserver.jar contains the 'problem' connection classes.)
>
> I might try seeing whether JDK 1.2.2-001 fixes the problem, but
> you'd have thought something as basic as JAR format or reading
> from a JAR would be correct.
>
> Hopefully the rest will be more straight forward, and you won't
> get any other silly config questions from me.
>
> Cheers,
>
> Jonathan
>
> > -----Original Message-----
> > From: Sheldon Wosnick [mailto:swosnick@hotmail.com]
> > Sent: 23 April 2000 22:30
> > To: jgc-home@bigfoot.com
> > Cc: tomcat-user@jakarta.apache.org
> > Subject: RE: Tomcat installation problem
> >
> >
> > Jonathan,
> >
> > Out of curiosity, do you get the same the same ClassNotFound
> > exception when
> > you first unjar the four .jar files to a common directory and
> > then add THAT
> > directory to the classpath instead (of the .jar file).
> >
> > That is, create a directory, say, _classes and unjar:
> >
> > webserver.jar
> > xml.jar
> > servlet.jar
> > jasper.jar
> >
> > then append the classpath to \_classes.
> >
> > I had some problems with some JDKs/versions of VA/Java with
> > classpath that
> > mysteriously work fine when the .jar files are first unjarred.
> >
> > Regards,
> >
> > Sheldon Bradley Wosnick
> > Software Developer, IBM VisualAge for Java, Web Tools
> > IBM Toronto Lab
> > work: swosnick@ca.ibm.com
> > personal: swosnick@hotmail.com
>
>
> --------------------------------------------------------------------------
> To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commmands, email: tomcat-user-help@jakarta.apache.org
>


Mime
View raw message