tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Franky Mas de Xaxás <fm...@nexo.es>
Subject Thanks and more
Date Tue, 18 Apr 2000 18:49:16 GMT
Thank you very much Maksym and Marcus,

you both were right. I had some problems with my paths.

Now I got Tomcat running with Apache on Windows 95. 

I'm really new on this technogy, so excuse me if I abuse from your time. What I want to do
is run Java Server Pages with Apache, and later on get in touch with servlets, JavaBeans,
XML and so on.

But, I still don't have Tomcat rigt working with Apache, because whenever I try to execute
a JavaServerPage, I get the message "Page not found" so:

COULD YOU SEND ME A LITTLE EXAMPLE THAT SHOWS HOW TO RUN A JAVASERVERPAGE WITH TOMCAT 3.1
AND APACHE 1.3.9?
WHERE DO I HAVE TO STORAGE THE .JSP PAGES?

Thank you very much for advanced.

PS: I have good experience working with Oracle 8 and designing data models for datawarehousing,
so if you need any help I'll be glad to colaborate with you.

Regards,

Franky
  ----- Original Message ----- 
  From: Marcus Conti 
  To: tomcat-user@jakarta.apache.org 
  Sent: Monday, April 17, 2000 10:58 PM
  Subject: Re: Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tomcat/sta


  Franky, 
  i got the same error (also on Windows 9X), in my case it was because i had not set the environment
variables TOMCAT_HOME and JAVA_HOME.  either set them in your autoexec.bat or in the tomcat.bat
that comes with Tomcat 3.1. 
  e.g. in tomcat.bat add the following lines after "set cp=%CLASSPATH%" 
  set TOMCAT_HOME=c:\jakarta-tomcat 
  set JAVA_HOME=c:\java\jdk 
  replace c:\jakarta-tomcat with directory you installed tomcat to and replace c:\java\jdk
with directory where your java jdk is installed.  point both variables to the directory that
conatins the "lib" directory not to the lib directory itself. 
  hope this solves the problem. 
  Marcus 

  -- 
  Marcus Conti, MCP 
  Internet Application Developer 
  -Loki Technologies- 
  "Internet Solutions for Attorneys" 
  Email: mconti@lokitech.com 
  Office: (301)656-5503 
  Web: http://www.lokitech.com 
    

  Franky Mas de Xaxás wrote: 

    Hi Maksym, thank you very much for your quick response. Frome your email I realize that
the mising class should be inside webserver.jar.I think I'm using Tomcat (3.1) since I downloaded
from http://jakarta.apache.org/builds/tomcat/release/v3.1_beta_1/bin/jakarta_tomcat.zip Do
you know why the class org/apache/tomcat/startup/Tomcat doesn't appear in webserver.jar. Thank
you again. Franky:  fmasf@nexo.es 
      ----- Original Message -----
      From: Volkov, Maxim
      To: 'tomcat-user@jakarta.apache.org'
      Sent: Monday, April 17, 2000 12:57 PM
      Subject: RE: Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tomcat/sta
       Looks like you are using old Tomcat (3.0), according to your classpath.The problem
might be that startup/tomcat is provided for new Tomcat 3.1 and its webserver.jar is located
at different path.Check your pathsGood luck! Sincerely Yours, 
      Maksym Volkov, 
      Technical Writer, 
      Telesens Ukraine Ltd. 
      phone: +(380 572)190-567 (205) 
      e-mail: M.Volkov@telesens.com.ua 
      www.telesens.com.ua 
      Ideas expressed in this message are my own and not necessarily reflect that of my employer.


        -----Original Message----- 
        From: Franky Mas de Xaxas [mailto:fmasf@nexo.es] 
        Sent: Monday, April 17, 2000 12:56 
        To: tomcat-user@jakarta.apache.org 
        Subject: Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tomcat/sta

         
          
        Hi, Im triying to run Tomcat on Windows 95 but I get one error: It seems I don't have
the class named org/apache/tomcat/startup/Tomcat, since I get the error listed below when
I try to execute the comand 'tomcat run' 
          C:\APPS\jakarta-tomcat\bin>tomcat run 
          Using classpath: C:\APPS\JAKART~1\BIN\classes;C:\APPS\JAKART~1\BIN\lib\webserver

          .jar;C:\APPS\JAKART~1\BIN\lib\jasper.jar;C:\APPS\JAKART~1\BIN\lib\xml.jar;C:\APP

          S\JAKART~1\BIN\lib\servlet.jar;C:\jdk1.2.2\lib\tools.jar;C:\APPS\JAKART~1\BIN\cl

          asses;C:\APPS\JAKART~1\BIN\lib\webserver.jar;C:\APPS\JAKART~1\BIN\lib\jasper.jar

          ;C:\APPS\JAKART~1\BIN\lib\xml.jar;C:\APPS\JAKART~1\BIN\lib\servlet.jar;C:\jdk1.2

          .2\lib\tools.jar 
          Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tomcat/sta

          rtup/Tomcat
        Maybe I should try to work with the file tomcat.properties? Any one could help? Thanks
for advanced! ----------------Franky:  fmasf@nexo.es

    
    

Mime
View raw message