tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy J. Buege" <tjbu...@visi.com>
Subject Re: Tomcat and IIS 4.0
Date Mon, 03 Apr 2000 18:05:27 GMT
Ok, I set JAVA_HOME=c:\jdk1.2.2 and now JSP pages work.  Thanks!

Question:  Where is this stuff documented?  I feel as if I'm missing some
important piece here, given all the trouble I had setting this up.

P.S.  Nacho, did you know when you post to this list, you "double post"
(i.e., I see two identical messages from you).

Thanks again!

Tim
tjbuege@visi.com

----- Original Message -----
From: "Nacho" <nacho@siapi.es>
To: <tomcat-user@jakarta.apache.org>; "'Timothy J. Buege'"
<tjbuege@visi.com>
Sent: Monday, April 03, 2000 12:19 PM
Subject: RE: Tomcat and IIS 4.0


> Hi timothy, it's fine, the next is to have defined JAVA_HOME when
> startup.bat starts, this for jdk1.2 ( you use it no?)
>
> Saludos ,
> Ignacio J. Ortega
>
>
> > -----Mensaje original-----
> > De: Timothy J. Buege [mailto:tjbuege@visi.com]
> > Enviado el: lunes 3 de abril de 2000 19:05
> > Para: tomcat-user@jakarta.apache.org
> > Asunto: Re: Tomcat and IIS 4.0
> >
> >
> > Ok, this is what my problem was.  I downloaded the files
> > using Netscape
> > Communicator 4.61.  Nacho was kind enough to send me his
> > version of the
> > isapi_redirect.dll file, and it worked for me.  Then, I tried
> > downloading
> > the file again, this time using IE 5.01.  That file works, as
> > well.  It's
> > the same size as the one Nacho sent me.
> >
> > So, it appears to be a problem when downloading files via Netscape.
> >
> > Now that I have the isapi link working, the example JSP pages
> > refuse to run.
> > I'm receiving an error message in the TomCat window:
> > java.lang.NoClassDefFoundError: sun/tools/javac/Main.  None of the JSP
> > examples work, but all of the Servlet examples work.
> >
> > Any ideas?  I suspect there's something wrong with my
> > CLASSPATH setting:
> >
> >
> > CLASSPATH=..\classes;..\lib\webserver.jar;..\lib\jasper.jar;..
> > \lib\xml.jar;.
> > .\lib\servlet.jar;\lib\tools.jar
> >
> > Thanks for all your help so far,
> >
> > Tim
> > tjbuege@visi.com
> >
> > ----- Original Message -----
> > From: "Sim IJskes" <sim@nyx.xs4all.nl>
> > To: <tomcat-user@jakarta.apache.org>
> > Sent: Monday, April 03, 2000 7:17 AM
> > Subject: Re: Tomcat and IIS 4.0
> >
> >
> > > Michael Lazlo wrote:
> > > >
> > > > Did you download "isapi_redirect.dll" using Netscape,
> > because Netscape
> > seems to
> > > > have a problem with downloading .dll's.  They are
> > actually sent as ASCII
> > & not
> > > > Binary, which is how it needs to be downloaded.  If this
> > is the case try
> > IE, I
> > > > can't even believe I would say to use a Microsoft product
> > over anything
> > else, it
> > > > does download a .dll as Binary.
> > > >
> > >
> > > Maybe we should bring this to the attention the the
> > webmaster. The url
> > >
> > >
> > http://jakarta.apache.org/builds/tomcat/release/v3.1_beta_1/bi
> n/win32/i386/i
> sapi_redirect.dll
> >
> > is sent with 'Content-Type: text/plain' when a HEAD is done. This is
> not
> > correct.
> >
> > Gr. Sim
> >
> >
> ------------------------------------------------------------------------
> --
> > To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> > For additional commmands, email: tomcat-user-help@jakarta.apache.org
> >
>
>
> ------------------------------------------------------------------------
> --
> To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commmands, email: tomcat-user-help@jakarta.apache.org
>
> --------------------------------------------------------------------------
> To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commmands, email: tomcat-user-help@jakarta.apache.org
>


Mime
View raw message