tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Arntson <bry...@ilm.com>
Subject setting environment values in tomcat 3.1beta
Date Tue, 21 Mar 2000 19:01:54 GMT
I am trying to set up some environment parameters in tomcat, so that I
can access them via the System.getProperty() command.  My understanding
is that I can do this in the web-app's web.xml file.  I have set up the
following bit of code:

<web-app>
...
...
<env-entry>
<env-entry-name>
PTS_MACHINE
</env-entry-name>
<env-entry-value>
dax
</env-entry-value>
<env-entry-type>
java.lang.String
</env-entry-type>
</env-entry>
...
...
</web-abb>

However, when I try to start tomcat with this entry, I get an error:

java.lang.NoSuchMethodException: addTaglib
        at java.lang.Class.getMethod0(Native Method)
        at java.lang.Class.getMethod0(Compiled Code)
        at java.lang.Class.getMethod(Compiled Code)
        at org.apache.tomcat.util.xml.MethodSetter.end(Compiled Code)
        at org.apache.tomcat.util.xml.XmlMapper.matchEnd(Compiled Code)
        at org.apache.tomcat.util.xml.XmlMapper.endElement(Compiled
Code)
        at com.sun.xml.parser.Parser.maybeElement(Compiled Code)
        at com.sun.xml.parser.Parser.content(Compiled Code)
        at com.sun.xml.parser.Parser.maybeElement(Compiled Code)
        at com.sun.xml.parser.Parser.parseInternal(Compiled Code)
        at com.sun.xml.parser.Parser.parse(Parser.java:283)
        at
org.apache.tomcat.util.xml.XmlMapper.readXml(XmlMapper.java:198)
        at
org.apache.tomcat.context.WebXmlReader.processFile(WebXmlReader.java:124)

        at
org.apache.tomcat.context.WebXmlReader.contextInit(WebXmlReader.java:38)

        at org.apache.tomcat.core.ContextManager.initContext(Compiled
Code)
        at org.apache.tomcat.core.ContextManager.init(Compiled Code)
        at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:123)
        at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:130)

is this a bug in Tomcat?  Should I report  this?  If not, what am I
doing wrong?  Any help would be greatly appreciated.

Thanks,

Bryan


Mime
View raw message