tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jascha Espley <Jascha_Esp...@telus.net>
Subject Re: ISAPI Redirector problems
Date Fri, 17 Mar 2000 21:52:51 GMT
Stop the press!!  Got it working!  There is a discrepancy between the file name for
the worker.properties file in the CVS and the registry entry in the instructions.
In the CVS where you can download the file, it is called workers.properties... and
in the instructions where it tells you to make the registry entry, it calls it
worker.properties  (notice:  worker vs workers... somebody pluralized it)

Thanks everyone for your help,
Jascha Espley

Jascha Espley wrote:

> Sorry, that was a typo in my email.  The registry entry on my computer is
> correct.  This problem baffles me.  I wonder if anyone else has managed to get
> this working....  Perhaps the DLL on the jakarta site is corrupted.  Does anyone
> have a copy of the DLL that they know for sure works?
>
> Jascha
>
> Barbara Nelson wrote:
>
> > Did you rename the URI map file?  In tomcat, it is called
> > uriworkermap.properties. I noticed that in your registry entry you are
> > calling it uriworker.properties.  Is this a typo?  Make sure that the
> > registry entry matches what the file is called, and where it is located on
> > your system.
> >
> > Hope this helps!
> >
> > Barbara Nelson.
> >
> > -----Original Message-----
> > From: Jascha Espley [mailto:Jascha_Espley@telus.net]
> > Sent: Friday, March 17, 2000 1:39 PM
> > To: tomcat-user@jakarta.apache.org
> > Subject: Re: ISAPI Redirector problems
> >
> > Yes, i have stopped and restarted the IIS service.  There is a red down
> > arrow
> > beside the filter.  And for priority it says "Unknown".  No log file has
> > been
> > created in the path i specified for the log file.  Any suggestions?
> >
> > Thanks,
> > Jascha Espley
> >
> > Barbara Nelson wrote:
> >
> > > Have you stopped and restarted the IIS service (not just the admin
> > console)?
> > > Does it show with a red downward arrow, or no arrow at all?  If it is a
> > red
> > > downward arrow, look in the logfile c:\InetPub\tomcat\isapi.log.  It may
> > > explain why the filter is failing to load.  If it has no arrow at all, it
> > > sounds as if you haven't restarted IIS.
> > >
> > > Barbara Nelson.
> > >
> > > -----Original Message-----
> > > From: Jascha Espley [mailto:Jascha_Espley@telus.net]
> > > Sent: Friday, March 17, 2000 1:31 PM
> > > To: tomcat-user@jakarta.apache.org
> > > Subject: Re: ISAPI Redirector problems
> > >
> > > I've tried downloading the DLL using different methods, i'm pretty sure it
> > > isn't
> > > corrupt, as it is 96KB.
> > >
> > > As for the registry entries, this is what i entered in:
> > >
> > > Ok, i've created theses two keys in the registry:
> > >
> > > HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi
> > > Redirector
> > > HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi
> > > Redirector\1.0
> > >
> > > I've created these string values under the 1.0 key:
> > >
> > > extension_uri    "/jakarta/isapi_redirect.dll"
> > > log_file            "c:\Inetpub\tomcat\isapi.log"
> > > log_level            "debug"
> > > worker_file        "c:\Inetpub\tomcat\conf\worker.properties"
> > > worker_mount_file    "c:\Inetpub\tomcat\conf\uriworker.properties"
> > >
> > > This is exactly what i have entered...and it is exactly from the
> > > instructions
> > > that are available.  The filter will still not display with a little green
> > > arrow
> > > pointing up in IIS 4.0.  What am i doing wrong?
> > >
> > > Thanks,
> > > Jascha Espley
> > >
> > > --------------------------------------------------------------------------
> > > To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> > > For additional commmands, email: tomcat-user-help@jakarta.apache.org
> > >
> > > --------------------------------------------------------------------------
> > > To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> > > For additional commmands, email: tomcat-user-help@jakarta.apache.org
> >
> > --------------------------------------------------------------------------
> > To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> > For additional commmands, email: tomcat-user-help@jakarta.apache.org
> >
> > --------------------------------------------------------------------------
> > To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> > For additional commmands, email: tomcat-user-help@jakarta.apache.org
>
> --------------------------------------------------------------------------
> To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commmands, email: tomcat-user-help@jakarta.apache.org


Mime
View raw message