tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From slb <...@heidi.acc.virginia.edu>
Subject mod_jserv.so for AIX?
Date Wed, 29 Mar 2000 18:33:15 GMT
I'll follow up on my own question since I managed
to get it to link.  First of all, ld seems
to need two additional libraries beyond libc that
apxs knew about - libcfg and libodm.  Also you have
to explicitly tell the linker what symbols to export
for a shared module under AIX.  You can either make
an ascii file with a list and pass it to the linker
with the -bimport:<filename> flag or you can just
export the whole lot with the -bexpall flag.  Since
I had no idea what symbols were needed, I used the 
second option and had no problems with name conflicts.
It seems to be working for now.

sandy

------------- Begin Forwarded Message -------------

Date: Wed, 29 Mar 2000 09:46:51 -0500 (EST)
From: slb <slb@heidi.acc.Virginia.EDU>
Subject: mod_jserv.so for AIX?
To: tomcat-user@jakarta.apache.org
Mime-Version: 1.0
Content-MD5: DPNNqMmfj1AY4IkYQALu/w==

I'm trying to get tomcat running with Apache under
AIX 4.3.3.  So far I've got apache_1.3.12 compiled
and working with DSO enabled, and I have tomcat 3.1
compiled and working standalone.  I can't get a jserv
module linked, though.  Has anyone gottent this to 
work who would be willing to share the ld flags
that made it work for you? tia...

sandy bryant
sandy@virginia.edu


------------- End Forwarded Message -------------



Mime
View raw message