tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Bruce <chrisabr...@yahoo.com>
Subject Re: application web.xml question
Date Fri, 24 Mar 2000 21:50:33 GMT
I don't know if it is a bug, but you can add the following to the
web.xml in your /usr/www/site/webapps/blah/WEB-INF/ :

<servlet-mapping>
   <servlet-name>Control</servlet-name>
   <url-pattern>Control</url-pattern>
</servlet-mapping>

I think that should make /blah/Control (or anything in the context
ending in Control) to go to your class.


--- "Lloyd H. Meinholz" <meinholz@bmpcoe.org> wrote:
> Chris, thanks for the response. I hate to sound dense, but what do
> you
> mean by url-mapping? In apache???
> 
> I added some <servlet-mapping> to my web.xml, but that didn't seem to
> work either. I just wish I knew if this was a known bug or a config
> problem on my part...
> 
> Lloyd
> 
> 
> Chris Bruce wrote:
> > 
> > Lloyd,
> > 
> > A work around may be to use url-mapping.
> > 
> > --- "Lloyd H. Meinholz" <meinholz@bmpcoe.org> wrote:
> > > Is this bug 106 "named servlet dispatching is broken"? What is a
> > > named
> > > servlet? Thanks,
> > >
> > > Lloyd
> > >
> > >
> > > "Lloyd H. Meinholz" wrote:
> > > >
> > > > I am having difficulty getting <servlet-name> <servlet-class>
> > > working in
> > > > my applications web.xml.
> > > >
> > > > I have the following entry in the tomcat.conf file (included in
> > > > httpd.conf):
> > > > ApJServMount /blah /root
> > > >
> > > > in my server.xml:
> > > > <Context path="blah" docBase="/usr/www/site/webapps/blah"
> debug="0"
> > > > reloadable="true">
> > > > </Context>
> > > >
> > > > in /usr/www/site/webapps/blah/WEB-INF/web.xml
> > > > <web-app>
> > > >    <display-name>Blah</display-name>
> > > >    <servlet>
> > > >       <servlet-name>Control</servlet-name>
> > > >
> > >
> <servlet-class>org.bmpcoe.action.framework.Control</servlet-class>
> > > >    </servlet>
> > > > </web-app>
> > > >
> > > > I have left the default web.xml alone (the one in
> > > $TOMCAT_HOME/conf).
> > > >
> > > > /blah/org.bmpcoe.action.framework.Control works but,
> > > > /blah/Control doesn't. I've gone through the spec and the draft
> > > Users
> > > > Guide and don't know if I've done something wrong or if this is
> a
> > > bug.
> > > > Has anyone gotten functionality like this to work???
> 
>
--------------------------------------------------------------------------
> To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commmands, email: tomcat-user-help@jakarta.apache.org
> 
> 

__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com

Mime
View raw message