tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Cathrow" <acath...@seagull.nl>
Subject RE: .jar files in the lib directory
Date Fri, 24 Mar 2000 20:32:47 GMT
I had the same problem earlier and asked the same question.
Apartantly it's a known bug and it will be resolved.
In the meantime there is a workaround documented in bugzilla.
But I've not had too much luck trying to find it.

Aic

-----Original Message-----
From: Kabriel Robichaux [mailto:kabriel@netobjects.com]
Sent: 24 March 2000 19:05
To: 'tomcat-user@jakarta.apache.org'
Subject: .jar files in the lib directory


According to what documentation i have seen (such as the Servlet Spec) the
Servlet engine is supposed to automatically look for any classes it needs in
all jar files in the /lib directories of any web apps (contexts). I have a
simple web app that contains a Servlet class in the /classes directory and a
util.jar in the /lib directory of my /simpleapp context. For some reason (a
reason i hope someone in this group can point out) the Servlet engine is not
finding any of my classes that are in the util.jar file. If i include my jar
file in the system classpath then everything works correctly. The way i
understand it anything in the /lib dir should be loaded automatically
without having to be included on the system classpath. Is this correct? Is
there a way to get Tomcat to do this correctly? or is this a bug/feature
that has not yet been fixed/implemented ?

Any help would be greatly appreciated. Thank you.

....
Kabe

--------------------------------------------------------------------------
To unsubscribe, email: tomcat-user-unsubscribe@jakarta.apache.org
For additional commmands, email: tomcat-user-help@jakarta.apache.org


Mime
View raw message