tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Bayern <bay...@essentially.net>
Subject Re: JSP compile error
Date Thu, 12 Sep 2002 14:12:18 GMT
On Thu, 12 Sep 2002, Thomas, Bobby P wrote:

> I would really appreciate if anyone could help me with an error while the
> JSP engine tries to compile my JSP. I am using iPlanet WebServer which
> utilizes jakarta's Jasper JSP Enginer.
> 
> My JSP:
> <%@ taglib prefix="util" uri="/../web-inf/util.tld"%>
> <util:prop prps="lookmeup" key="language" scope="application"
> var="language"/>  (line 17)
> 
> I get the error :
> JSP: JSP1x compiler threw exception
> org.apache.jasper.compiler.CompileException:
> C:\iPlanet\Servers\bin\https\webapps\phonebook-app\search.jsp(17,0) Unable
> to load class null at
> org.apache.jasper.compiler.TagBeginGenerator.init(TagBeginGenerator.java:128
> ) .
> 
> What could be a possible reason for the error and how can I fix it? Any help
> would be greatly appreciated.

It's likely to be an error in your TLD.  Could you display the entry for
the <prop> tag in util.tld?  I'm not an iPlanet user, but off the top of
my head, a few things to look out for include a packageless class as your
<tagclass> or some other irregularity related to that mapping.

-- 
Shawn Bayern
"JSTL in Action"   http://www.jstlbook.com


--
To unsubscribe, e-mail:   <mailto:taglibs-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:taglibs-user-help@jakarta.apache.org>


Mime
View raw message