tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ari Suutari <ari.suut...@syncrontech.com>
Subject Fwd: Re: Tomcat 4.1.10 and tag pooling problem
Date Wed, 04 Sep 2002 10:32:23 GMT
Hi,

There is some kind of problem using i18n tags and
new tomcat 4.1.10 tag pooling. Does anyone know
what should be done to i18n to make it work ?

	Ari S.

----------  Forwarded Message  ----------

Subject: Re: Tomcat 4.1.10 and tag pooling problem
Date: Wed, 04 Sep 2002 11:35:28 +0200
From: Remy Maucherat <remm@apache.org>
To: Tomcat Developers List <tomcat-dev@jakarta.apache.org>

Ari Suutari wrote:
> Hi,
>
> I have been testing tomcat 4.1.10 with our web application,
> which uses i18n tag from jakarta-taglibs. When running
> it under 4.1.10 with jsp default settings in web.xml it
> produces very odd results - it seems that each i18n tag
> return same string to page (the string might be the
> one the first tag returns, I'm not sure). When
> I add
>
>         <init-param>
>             <param-name>enablePooling</param-name>
>             <param-value>false</param-value>
>         </init-param>
>
> to web.xml, the application works perfectly and the result
> is similar as in tomcat 4.0.x.

The tag is likely not compliant with the specification, which defines
how a tag instance may be reused (and TC 4.1 takes advantage of that to
lower the amount of object creation).

Remy


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>

-------------------------------------------------------


--
To unsubscribe, e-mail:   <mailto:taglibs-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:taglibs-user-help@jakarta.apache.org>


Mime
View raw message