tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james_strac...@yahoo.co.uk>
Subject xtags supports JSP scopes (was Re: error with xtags and tomcat 3.3)
Date Fri, 09 Nov 2001 18:27:17 GMT
Hi Richard

Also while patching the code I've also added support for explicit JSP
scopes. So that in XPath expressions the following expressions can now be
used...

$page:foo    -> page scope "foo"
$request:foo    -> request scope "foo"
$session:foo    -> session scope "foo"
$app:foo    -> applicaiton scope "foo"

$param:foo -> request.getParameter( "foo" );
$initParam:foo -> context.getInitParameter( "foo" );

$header:foo -> request.getHeader( "foo" );
$cookie:foo        -> get Cookie for name "foo" and return Cookie.getValue()

e.g.

<xtags:if test="starts-with($header:agent, 'Mozilla')">
    ....
</xtags:if>

James
----- Original Message -----
From: "Richard Sand" <rsand@vgalleries.com>
To: <taglibs-user@jakarta.apache.org>
Sent: Thursday, November 08, 2001 1:20 AM
Subject: error with xtags and tomcat 3.3


> Hi- I am using the Nov 6 build of xtags and I just today upgraded my
tomcat
> from 3.2.2 to 3.3.  Suddenly, my jsp page using xtags will not work.  The
> error I get is:
>
> java.lang.AbstractMethodError:
> org/apache/taglibs/xtags/util/JspVariableContext.getVariableValue
> at org.jaxen.ContextSupport.getVariableValue(ContextSupport.java:97)
> at org.jaxen.Context.getVariableValue(Context.java:57)
> at
>
org.jaxen.expr.DefaultVariableReferenceExpr.evaluate(DefaultVariableReferenc
> eExpr.java:60)
> at org.jaxen.expr.DefaultXPath.asList(DefaultXPath.java:46)
> at org.jaxen.JaXPath.jaSelectNodes(JaXPath.java:35)
> at org.jaxen.JaXPath.jaSelectSingleNode(JaXPath.java:40)
> at org.jaxen.JaXPath.jaValueOf(JaXPath.java:52)
> at org.jaxen.BaseXPath.valueOf(BaseXPath.java:32)
> at org.dom4j.xpath.DefaultXPath.valueOf(DefaultXPath.java:169)
> at
> org.apache.taglibs.xtags.xpath.VariableTag.doStartTag(VariableTag.java:99)
> at help.help_1._jspService(help_1.java, Compiled Code)
> .......etc.
>
> I'm suspecting a version conflict in one of the jar files but I haven't
been
> able to track it down.  Anyone have any suggestions?  I'm also using the
> most recent dom4j-full.jar.
>
> Thanks!
>
> Best regards,
>
> Richard
>
>
>
>
>
> --
> To unsubscribe, e-mail:
<mailto:taglibs-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:taglibs-user-help@jakarta.apache.org>
>
>


_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com


--
To unsubscribe, e-mail:   <mailto:taglibs-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:taglibs-user-help@jakarta.apache.org>


Mime
View raw message