tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yoli" <ybarqui...@tpi.es>
Subject Taglibs with attributes using iPlanet
Date Wed, 14 Nov 2001 15:21:45 GMT
Hi all.
I am trying to develop taglibs using iPlanet.
The problem is the following:
Although i can execute taglibs without attributes correctly when trying to
execute one with attributes i have the following sequence of errors:

[14/nov/2001:13:19:57] info (  353): Internal Info: loading servlet
/jsps/Hello3.jsp
[14/nov/2001:13:19:57] warning (  353): Internal error: Unexpected Java
exception thrown (java.lang.NoSuchMethodError:
javax.servlet.jsp.tagext.TagAttributeInfo: method
(Ljava/lang/String;ZZLjava/lang/String;)V not
found,javax.servlet.jsp.tagext.TagAttributeInfo: method
(Ljava/lang/String;ZZLjava/lang/String;)V not found), stack:
java.lang.NoSuchMethodError: javax.servlet.jsp.tagext.TagAttributeInfo:
method (Ljava/lang/String;ZZLjava/lang/String;)V not found
 at
org.apache.jasper.compiler.TagLibraryInfoImpl.createAttribute(TagLibraryInfo
Impl.java:478)
 at
org.apache.jasper.compiler.TagLibraryInfoImpl.createTagInfo(TagLibraryInfoIm
pl.java:395)
 at
org.apache.jasper.compiler.TagLibraryInfoImpl.parseTLD(TagLibraryInfoImpl.ja
va:350)
 at
org.apache.jasper.compiler.TagLibraryInfoImpl.(TagLibraryInfoImpl.java:284)
 at
org.apache.jasper.compiler.JspParseEventListener.handleDirective(JspParseEve
ntListener.java:648)
 at
org.apache.jasper.compiler.DelegatingListener.handleDirective(DelegatingList
ener.java:110)
 at org.apache.jasper.compiler.Parser$Directive.accept(Parser.java:188)
 at org.apache.jasper.compiler.Parser.parse(Parser.java:1042)
 at org.apache.jasper.compiler.Parser.parse(Parser.java:1017)
 at org.apache.jasper.compiler.Parser.parse(Parser.java:1013)
 at org.apache.jasper.compiler.Compiler.compile(Compiler.java:163)
 at
com.netscape.server.http.servlet.NSServletEntity.load(NSServletEntity.java:2
31)
 at
com.netscape.server.http.servlet.NSServletEntity.update(NSServletEntity.java
:150)
 at
com.netscape.server.http.servlet.NSServletRunner.Service(NSServletRunner.jav
a:446)

Can anyone help me?.I don't know if it is a problem with the configuration
of iPlanet or with another thing.Has anyone had this type of problem?.How to
solve it?.

Thanks in advance.
Yolanda



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message