tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Smedts, Alain" <Alain.Sme...@be.compuware.com>
Subject RE: HELP: why scrape result does not show??
Date Thu, 14 Jun 2001 08:05:30 GMT
Hi,

I have the same problem. In my servlet.log I have the following error:
2001-06-14 09:43:49 - path="/scrape-examples"
:java.net.UnknownHostException: weather.noaa.gov
This error probably comes from the fact that we don't have a DNS server
(i.e. ping weather.noaa.gov fails)

When I change in scrape.jsp the line:
        <scrp:page
url="http://weather.noaa.gov/cgi-bin/fmtbltn.pl?file=forecasts/city/mo/colum
bia.txt" time="11">
to
        <scrp:page
url="http://205.156.51.200/cgi-bin/fmtbltn.pl?file=forecasts/city/mo/columbi
a.txt" time="11">

I get the following error:
2001-06-14 09:56:51 - path="/scrape-examples"
:java.net.NoRouteToHostException: Host unreachable: connect

I believed this was due to the firewall, so I set
TOMCAT_OPTS=-Dhttp.proxyHost=<myproxy> -Dhttp.proxyPort=<myproxyport>. This
still doesn't work. Within my browser I have no problem going directly to:
http://weather.noaa.gov/cgi-bin/fmtbltn.pl?file=forecasts/city/mo/columbia.t
xt

Anyone any ideas?

TIA,

Alain


-----Original Message-----
From: yu chen [mailto:yu.chen@Sun.COM]
Sent: woensdag 13 juni 2001 23:35
To: JSP-INTEREST@JAVA.SUN.COM; taglibs-user@jakarta.apache.org
Subject: HELP: why scrape result does not show??


Hi, 

I just downloaded and configured the scrape tag lib. I,

- extracted scrape-20010523.tar and put the scrape/ in the webapps/
directory.  
- made sure the 2 jar files (scrape.jar & jakarta-oro-2.0.jar) are in
webapps/scrape/WEB-INFO/lib/
- made sure the descriptor file (scrape.tld) is in
webapps/scrape/WEB-INFO/
- added the following in file webapps/scrape/WEB-INFO/web.xml 
    <taglib>
        <taglib-uri>scrape.jar</taglib-uri>
        <taglib-location>/WEB-INF/scrape.tld</taglib-location>
    </taglib>

- restarted tomcat (3.2)
- I include j2sdk1_3_0/bin in my $PATH

But when I open http://hostname/scrape/scrape.jsp, I don't see the
scraped content but only the following, WHY?? Did I miss anything?


Thanks in advance. -yc

===========================     

Mime
View raw message