tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "kidong" <Kidong....@public.uni-hamburg.de>
Subject Re: Error 500 Messages
Date Tue, 13 Mar 2001 21:28:49 GMT
hello,

as my experience with J2EE1.2.1 server, it will work fine as follows:

<%@ taglib uri="/WEB-INF/tlds/dbtaglib.tld" prefix="sys" %>

--
   <taglib>
       <taglib-uri>/WEB-INF/tlds/dbtaglib.tld</taglib-uri>
       <taglib-location>/WEB-INF/tlds/dbtaglib.tld</taglib-location>
</taglib>
--

with tomcat3.2.1, it may run as follows:
<%@ taglib uri="/WEB-INF/dbtaglib.tld" prefix="sys" %>

--
   <taglib>
       <taglib-uri>/WEB-INF/dbtaglib.tld</taglib-uri>
     <taglib-location>/WEB-INF/dbtaglib.tld</taglib-location>
</taglib>
--
further information go to jakarta-tomcat 



----- Original Message ----- 
From: "Peter Leonardi" <pleonardi@aapt.com.au>
To: <taglibs-user@jakarta.apache.org>
Sent: Tuesday, March 13, 2001 9:04 AM
Subject: Error 500 Messages


> Taglibs Users
> 
> I'm finding difficulty in solving an error, I'm receiving the following error:
> 
> org.apache.jasper.compiler.CompileException: X:\jakarta-tomcat\webapps\engsys\sys\jsp\login\login.jsp(1,0)
Unable to open taglibrary /WEB-INF/tlds/dbtaglib.tld : X:\jakarta-tomcat\webapps\engsys\WEB-INF\web.xml
> 
> The following files have the correct paths specified within my directory
> Section of code from the related files:
> 
> file path: engsys/sys/WEB-INF/tlds/dbtaglib.tld
> 
> <taglib> 
>   <tlibversion>1.0</tlibversion>
>   <jspversion>1.1</jspversion>
>   <shortname>sys</shortname>
>   <uri>/dbtaglib</uri>
>   <info>
> System Engineerings Database Tag Library
>   </info> 
> </taglib> 
> 
> file path: engsys/sys/jsp/login/login.jsp
> Util class path: /engsys/src/proj/process.tracking/util/
> 
> <%@ page import="src.proj.process.tracking.util.*" %>
> <%@ taglib uri="/WEB-INF/tlds/dbtaglib.tld" prefix="sys" %>
> 
> file path: engsys/sys/WEB-INF/web.xml
> 
>   <taglib>
>     <taglib-uri>
>       /dbtaglib
>     </taglib-uri>
>     <taglib-location>
>       /WEB-INF/tlds/dbtaglib.tld
>     </taglib-location>
>   </taglib>
> 
> 
> I have been trying to resolve this for over a day with no luck, I know it is probably
a simple error but I'm having no luck with any documentation.
> 
> Any assistance/insight would be greatly appreciated.
> 

Mime
View raw message