tomcat-taglibs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Scott" <msc...@outerforce.com>
Subject RE: jspService Error
Date Fri, 26 Jan 2001 15:43:57 GMT
Thanks, Whacking the j2ee.jar got rid of the ugly incompatible
object error...
Now with a simple JSP test:
http://localhost:7001/test.jsp?numtimes=10


<HTML>
<BODY>
<P>
<% int num = Integer.parseInt( request.getParameter("numtimes"));
	for (int i = 0; i < num; i++ )


%>
		HELLO WORLD !
<%      }
%>
</P>
</body>
</html>

I still get errors :
java.lang.LinkageError: Class javax/servlet/ServletConfig violates loader
constraints

so I 'm still not sure what configuration changes have occurred..

Here's the dump:

Fri Jan 26 10:34:18 EST 2001:<I> <ServletContext-General> Generated java
file: C
:\weblogic51\myserver\working\myoutput\jsps\_test.java
Fri Jan 26 10:34:23 EST 2001:<E> <ServletContext-General> Servlet failed
with Ex
ception
java.lang.LinkageError: Class javax/servlet/ServletConfig violates loader
constr
aints
        at myoutput.jsps._test._jspService(_test.java:59)
        at weblogic.servlet.jsp.JspBase.service(JspBase.java:27)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:105)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:123)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:742)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:686)
        at
weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
ContextManager.java:247)
        at
weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
a:361)
        at
weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:261)

        at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)

Fri Jan 26 10:36:06 EST 2001:<E> <ServletContext-General> Servlet failed
with Ex
ception
java.lang.IncompatibleClassChangeError
        at myoutput.jsps._test._isStale(_test.java:45)
        at
weblogic.servlet.internal.ServletStubImpl.isStale(ServletStubImpl.jav
a:199)
        at weblogic.servlet.jsp.JspStub.checkForReload(JspStub.java:90)
        at
weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.
java:168)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:99)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:742)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:686)
        at
weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
ContextManager.java:247)
        at
weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
a:361)
        at
weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:261)

-----Original Message-----
From: Ward, Jeff [mailto:jward@BenefitPoint.com]
Sent: Thursday, January 25, 2001 8:37 PM
To: 'taglibs-user@jakarta.apache.org'
Subject: RE: jspService Error


  Why did you add j2ee.jar? It is probably causing the error, I can't
imagine that WL likes having another J2EE server's classes in it's class
path. I just dropped it into my server and it stopped working.(Not the same
exception but I am on a different Service Pack) Also, WL has made a lot of
changes regarding tags since 51 launched. I don't know how practical it is
for you to switch but you really should explore SP6 or SP8 (SP8 is best for
NT, Solaris. SP6 is best for Linux, HP).
  Every time WL sees a web app it creates a _tmp_war or _tmp_war_general in
the WEB-INF directory, sometimes it forgets the files in there are out of
date. If it's there wax it.
  Hope this helps.
  -Jeff Ward

 -----Original Message-----
From: 	Mark Scott [mailto:mscott@outerforce.com]
Sent:	Thursday, January 25, 2001 4:41 PM
To:	taglibs-user@jakarta.apache.org
Subject:	RE: jspService Error

I've gotten the taglibs to work previously in 51, I'll be setting 60
up on solaris friday...
>What service pack/vm/os?
no service pack, jdk 1.3, win2000 local instance
>How are you deploying
straight tld reference, no webapp yet...
>Did it work and then stop after modifying the page?
worked fine, no modifications just new pages with taglibs, now test page is
no good.
>Have you tried waxing the temp_war directory?
no, would there be one even if I'm only referencing the tld, not through
web.xml
>What is the full dump from WL?

Thu Jan 25 19:20:59 EST 2001:<I> <WebLogicServer> WebLogic Server started
Thu Jan 25 19:21:14 EST 2001:<I> <ServletContext-General> *.jsp: init
Thu Jan 25 19:21:14 EST 2001:<I> <ServletContext-General> looking for taglib
uri
 TagTest.tld as resource /WEB-INF/TagTest.tld in Web Application root:
Thu Jan 25 19:21:16 EST 2001:<I> <ServletContext-General> Generated java
file: C
:\weblogic\myserver\classfiles\myserver\classfiles\_test\_tagpage.java
Thu Jan 25 19:21:27 EST 2001:<E> <ServletContext-General> Servlet failed
with Ex
ception
java.lang.VerifyError: (class: myserver/classfiles/_test/_tagpage, method:
_jspS
ervice signature:
(Ljavax/servlet/http/HttpServletRequest;Ljavax/servlet/http/Ht
tpServletResponse;)V) Incompatible object argument for function call
        at java.lang.Class.newInstance0(Native Method)
        at java.lang.Class.newInstance(Class.java:237)
        at
weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubIm
pl.java:365)
        at
weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStub
Impl.java:349)
        at
weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubI
mpl.java:338)
        at weblogic.servlet.jsp.JspStub.prepareServlet(JspStub.java:185)
        at
weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.
java:164)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:99)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:123)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:742)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:686)
        at
weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
ContextManager.java:247)
        at
weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
a:361)
        at
weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:261)

        at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)


> Did you just switch Service Packs?
installed j2ee.jar, and implementing Input Taglib
thanks,
Mark

-----Original Message-----
From: Ward, Jeff [mailto:jward@BenefitPoint.com]
Sent: Thursday, January 25, 2001 6:58 PM
To: 'taglibs-user@jakarta.apache.org'
Subject: RE: jspService Error


  What service pack/vm/os? How are you deploying (unpacked web app or war
file)? Did it work and then stop after modifying the page? Have you tried
waxing the temp_war directory? (or temp_war_general depending on the service
pack) Have you ever gotten a taglib to work in 51? What is the full dump
from WL? And finally... Did you just switch Service Packs?
  Taglibs in WL are my specialty :)
  -Jeff Ward

 -----Original Message-----
From: 	Mark Scott [mailto:mscott@outerforce.com]
Sent:	Thursday, January 25, 2001 3:54 PM
To:	taglibs-user@jakarta.apache.org
Subject:	FW: jspService Error

From: Mark Scott [mailto:mscott@outerforce.com]
Sent: Thursday, January 25, 2001 6:41 PM
To: taglibs-user@jakart.apache.org
Subject: jspService Error


I'm using Tablibs & JSP's in weblogic 51
Jspservice( ) method giving error...
java.lang.VerifyError:
(class: myserver/classfiles/_myform, method: _jspService signature:
(Ljavax/servlet/http/HttpServletRequest;Ljavax/servlet/http/HttpServletRespo
nse;)V)
Incompatible object argument for function call
at java.lang.Class.newInstance0(Native Method)
at java.lang.Class.newInstance(Class.java:237)
any thoughts ?



Mime
View raw message