tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 63904] Apache http (with mod_jk to tomcat) randomly return empty response
Date Tue, 05 Nov 2019 23:32:01 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=63904

Christopher Schultz <chris@christopherschultz.net> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|---                         |INVALID
             Status|NEW                         |RESOLVED

--- Comment #1 from Christopher Schultz <chris@christopherschultz.net> ---
The log shows that mod_jk can't tell whether the request was processed or not:

> Client failed in the middle of request, we can't recover to another instance.

mod_jk can't prove that the request could be idempotent, so failing-over to
another server might be disastrous. There is nothing to be done but to fail the
request.

This is intended behavior in this case.

My recommendation would be for you to review all your various timeouts to make
sure mod_jk and Tomcat agree. Enable CPING/CPONG on the mod_jk end. See if that
improves anything.

If things are still behaving oddly, please post to the users list, as Bugzilla
is not intended to be a support forum. We can always re-open this bug if there
is indeed a bug (though mod_jk works in huge numbers of environments without
problems, so a bug is unlikely).

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message