tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Had trouble building libtcnative [openssl]
Date Mon, 08 May 2017 18:47:41 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

All,

On 5/8/17 2:23 PM, Christopher Schultz wrote:
> All,
> 
> I'm trying to do a complete test of 8.5.15 (candidate) and I can't 
> seem to build tcnative because of the OpenSSL dependency.
> 
> On my system, I've got OpensSSL 1.0.1t installed globally, but I
> have openssl 1.0.2f installed locally for the purposes of building 
> tcnative. This has worked in the past. When I run configure, it's 
> telling me that I have 1.0.1t available:
> 
> checking for OpenSSL library... using openssl from 
> /usr/${exec_prefix}/lib and /usr/include checking OpenSSL library
> version >= 1.0.2...
> 
> Found   OPENSSL_VERSION_NUMBER 0x1000114f (OpenSSL 1.0.1t  3 May
> 2016) Require OPENSSL_VERSION_NUMBER 0x1000200f or greater (1.0.2) 
> configure: error: Your version of OpenSSL is not compatible with
> this version of tcnative
> 
> If I specify --with-ssl, it's giving me roughly the same behavior:
> 
> checking for OpenSSL library... using openssl from 
> /home/cschultz/projects/apache-tomcat/openssl-1.0.2f/${exec_prefix}/li
b
>
> 
and
> /home/cschultz/projects/apache-tomcat/openssl-1.0.2f/include 
> checking OpenSSL library version >= 1.0.2... configure: error:
> Your version of OpenSSL is not compatible with this version of
> tcnative
> 
> Oddly, it doesn't tell me what my current version actually is.
> 
> In the openssl-1.0.2f directory, I have the expected libssl.*
> files but there was no "lib" directory, so I created a lib/
> directory and symlinked all of the ../libssl.* files into it.
> 
> Running openssl-1.0.2f/apps/openssl version confirms that the 
> command-line app has the proper OpenSSL version, and it's using
> the right version of the shared library (confirmed with ldd). It
> looks like I was missing the symlinks for the libcrypto.* objects.
> Once I added those symlinks, I was able to call configure.
> 
> AFAIK, my openssl-1.0.2f/ local directory is a legitimately-built 
> OpenSSL, but the tcnative build process is looking for things in
> odd places. I realize that 1.0.2f is a bit behind the times (1+
> year old) but has the build process changed that much? Also, what
> about people using these older versions?
> 
> I'm building 1.0.2k from source now to see if any post-build 
> modifications need to made in order for tcnative's build to
> pick-up the libraries, headers, etc. from that version.

A fresh build of 1.0.2k allows tcnative to build out-of-the box with
no alterations. I may go back and try 1.0.2f again just to see... the
openssl build seems not very repeatable.

For example, if I do "./config && make" I won't get any .so files. If
I then run "./config shared && make" the build fails with a
nonsensical error message. Basically, you either have to "make clean"
or just blow-away the local copy and re-build from scratch (which was
what I did) in order to get a working build.

- -chris
-----BEGIN PGP SIGNATURE-----
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJZEL1NAAoJEBzwKT+lPKRYRgMP/i7rlD7C/xBNUzPVcT1tAJ/p
KDjWJ1SoecA8FTtuY1cJx7Rd12HoeLeCspVaeeXaBG2kaskIK+qDxjSNQBQ85CgG
mvm8QQq7tvxUsa00x3rms/HXcR4/NLLbCd40Cn6GHBBsBvuirQxMG1i0Kwp+p7WY
l9e9tu9klqqc3pmxHAGSjZjPmrivw5Ag6FYGKjrwQDRSCyWLfp6D6UiH/pge6iLY
rhJ43xYrx2UAidwk8MULWQFsGZoCpLxX/1Q1TYdsCJKB8K17NT0ErMYPjygJymK0
syI6bmtvA9t+7iyUwc8G6oLzSm04bmQ5RdkS5hxgaFUt2JOqnI7yIt47Hs/OJ+uk
OfPaQO1mVhYkNwaI9QdkX5H7LyyRiABHHNKhK7OAbolT0ckySAAzhP02VpPYUUIW
vkEdaPS18sihZGufUXJtxfBlxiRwe3Rv7SoSpnUgwnmXfUI5d8in5AJsGay+6fEb
cYEh4cjkd3RgX7YthFU/j3Sk8m4N7pNIuykHSkZQpu9YWpYfhjxnulLGAt5f/9YM
1wzH7pDxs1f+8Q8weDG1Y26MA2NM6O4OW4FqfiUJIqZWYbS3FOv4imArmypkMfBD
1t7WTTVoVn1F1if6tX37W89JEFlV/j0JiW7AoiGq5Q8uhxYGFc12/LPmsVL7al/s
erCk6jE3FQki88S5ucvd
=Mipo
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message