tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 60394] Unreliable 'ant test' on Oracle JDK 7 due to certificate error
Date Sat, 26 Nov 2016 01:15:33 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=60394

--- Comment #5 from Michael Osipov <1983-01-06@gmx.net> ---
(In reply to Mark Thomas from comment #2)
> This is going to become increasingly problematic given the long lifetime of
> a Tomcat release compared to the lifetime of public Java releases. The pace
> of change of what is considered a minimal acceptable TLS configuration is
> also likely to cause problems.
> 
> Users building locally can use a newer JDK. If they want to build using an
> older JDK because that is the version they are using in production then the
> expectation is that they use a supported JDK which should include any
> necessary updates.
> 
> Release managers can work-around this by downloading manually or specifying
> a specific mirror.
> 
> If we start to see issues with the CI system then we can use the same
> options as the release managers.
> 
> At this point, I don't think we should start switching mirrors because
> people want to build with unsupported software. If the problem becomes more
> significant, we can re-evaluate.

I don't expect a bullet-proof fix.

I do use Java 8, but wanted simply to indicate that this may be an issue to
others. It should be at least documented on BUILDING.txt.

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message