tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 60368] Embedded org.apache.catalina.startup.Tomcat instance can no longer be started without a Connector
Date Mon, 14 Nov 2016 16:10:17 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=60368

Andy Wilkinson <awilkinson@pivotal.io> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|FIXED                       |---
             Status|RESOLVED                    |REOPENED

--- Comment #5 from Andy Wilkinson <awilkinson@pivotal.io> ---
Thanks, Mark. I've tried the snapshot and, unfortunately, it hasn't restored
the previous behaviour.

The latest change relies on getConnector() being called directly on the Tomcat
instance. Our code that works with 8.5.6 doesn't call getConnector(), instead
it retrieves the Connectors from their Services:
https://github.com/spring-projects/spring-boot/blob/6aa57e8ffe0a868fa5ed081f784015f3463022b3/spring-boot/src/main/java/org/springframework/boot/context/embedded/tomcat/TomcatEmbeddedServletContainer.java#L138-L146.
As a result the new defaultConnectorCreated flag remains false and when start
is called the default connector is created when previously it was not.

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message