tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: [VOTE] Release Apache Tomcat 8.0.25
Date Mon, 17 Aug 2015 21:09:13 GMT
Mark,

On 8/17/15 4:54 PM, Mark Thomas wrote:
> On 17/08/2015 21:10, Christopher Schultz wrote:
>> Mark,
>>
>> On 8/17/15 1:46 PM, Mark Thomas wrote:
>>> The proposed Apache Tomcat 8.0.25 release is now available for voting.
>>>
>>> The main changes since 8.0.24 are:
>>>
>>> - Fix EOF handling in the AJP APR/native connector to avoid the tight
>>>   loop that caused high CPU load
>>>
>>> - Avoid an NPE when adding POJO WEebSocket endpoints programmatically
>>>
>>> - Improved handling of async timeouts
>>>
>>>
>>> There is the usual collection of bug fixes, new features and
>>> performance improvements. For full details, see the changelog:
>>> http://svn.us.apache.org/repos/asf/tomcat/tc8.0.x/trunk/webapps/docs/changelog.xml
>>>
>>> It can be obtained from:
>>> https://dist.apache.org/repos/dist/dev/tomcat/tomcat-8/v8.0.25/
>>> The Maven staging repo is:
>>> https://repository.apache.org/content/repositories/orgapachetomcat-1048/
>>> The svn tag is:
>>> http://svn.apache.org/repos/asf/tomcat/tc8.0.x/tags/TOMCAT_8_0_25/
>>>
>>> The proposed 8.0.24 release is:
>>> [ ] Broken - do not release
>>> [ ] Stable - go ahead and release as 8.0.25
>>
>> The standard build is broken:
> 
> <expletive />
> 
> I must have used Notepad rather than Notepad2 to edit changelog.xml to
> create the tag without the 'in development' release text and it added
> the BOM.
> 
> Happy to re-roll the release but it is going to have to wait until
> tomorrow now.
> 
> I'm now very glad I back-porting parallel running of the unit tests.

Note that this requires ant 1.9.4, while the build instructions
(http://tomcat.apache.org/tomcat-8.0-doc/building.html#Install_Apache_Ant_1.8.2_or_later)
mention only 1.8.2 or later. I suppose technically, "building" only
requires 1.8.2 while running the unit tests requires 1.9.4. It's
probably worth updating the web-based "Building" instructions.

It's worth noting that BUILDING.txt does in fact say that ant 1.9.5 or
later is required.

-chris


Mime
View raw message