tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 57815] Improve error message when OpenSSL does not support the requested highest SSLProtocol
Date Thu, 16 Apr 2015 22:39:53 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=57815

--- Comment #4 from Justin <crynax@yahoo.com> ---
Thanks for your time and contributions. I would definitely find both the
compile time and run time versions of OpenSSL helpful, at least while such
static restrictions exist.

Sadly Tomcat Native is not actively maintained in many distributions, e.g.
pulled from Fedora EPEL 6, at 1.1.30 in Fedora EPEL 7 (as of April 16, 2015).
OpenSSL will be more actively maintained, particularly for security concerns.
Might help many to support future protocols and ciphers.

Slightly off topic: have you or others considered alternatives to
OpenSSL/LibreSSL? Maybe GnuTLS, NSS, Botan?

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message