tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 57582] New: euro character and UMLAUTS issue in iso-8859-15 on tomcat7.0.57 but not on 8.0.18
Date Fri, 13 Feb 2015 14:55:31 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=57582

            Bug ID: 57582
           Summary: euro character and UMLAUTS issue in iso-8859-15 on
                    tomcat7.0.57 but not on 8.0.18
           Product: Tomcat 7
           Version: unspecified
          Hardware: PC
            Status: NEW
          Severity: critical
          Priority: P2
         Component: Manager
          Assignee: dev@tomcat.apache.org
          Reporter: psandeep01@gmail.com

Hello,
Pardon if i am unable to add right category for this bug being new here.
I have this strange issue. I am using Spring 3 MVC to build a java web app.
When I deploy it on tomcat 7.0.57, I am able to search through umlauts in my
app or rather I am able to receive it in controller as it is, but EURO '€'
character is displayed as '¤'. I am using ISO-8859-15 encoding.

But when I deploy same code in tomcat 8.0.18 (latest as of today), I am not
able to get UMLAUTS characters but EURO '€' character is displayed as it is
now. Though I have found workaround but I am curious about what is causing the
issue. It will help me gain more knowledge about such behavior.

I am not concerned about saving EURO as I have handled it after Controller
class.

Thanks in advance!

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message