tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 57458] New: Mixed up responses sent to wrong users
Date Sun, 18 Jan 2015 14:02:48 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=57458

            Bug ID: 57458
           Summary: Mixed up responses sent to wrong users
           Product: Tomcat 7
           Version: 7.0.39
          Hardware: PC
            Status: NEW
          Severity: critical
          Priority: P2
         Component: Connectors
          Assignee: dev@tomcat.apache.org
          Reporter: mahmoud.alyasein@gmail.com

Some of users reported that they came to be another user, after long
investigation using a JMeter scripts we're able to duplicate it, we found that
when stressing tomcat for a while using huge response (like download files or
big pages) some users got wrong response from another users and in some cases
users received images instead of html pages, in same time we got null pointer
coming from the connector (we are using
"org.apache.coyote.http11.Http11NioProtocol"), so we changed it to
"org.apache.coyote.http11.Http11Protocol" then we could not duplicated again
using the Http11Protocol protocol

We're using Tomcat 7.0.39 with JDK 1.6_10, is there is any known fix for this
issue and in which version?

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message