tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 57445] New: java.util.Map$Entry cannot be resolved - jsp's no longer compile under java8
Date Thu, 15 Jan 2015 10:09:28 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=57445

            Bug ID: 57445
           Summary: java.util.Map$Entry cannot be resolved - jsp's no
                    longer compile under java8
           Product: Tomcat 7
           Version: 7.0.56
          Hardware: All
                OS: Linux
            Status: NEW
          Severity: critical
          Priority: P2
         Component: Jasper
          Assignee: dev@tomcat.apache.org
          Reporter: hauser@acm.org

with tc7.0.28 from current debian stable I got the problem.

As per
http://stackoverflow.com/questions/19243458/tomcat7-not-compiling-jsp-examples
, I got a 7.0.56, but the problem still persists

org.apache.jasper.JasperException: Unable to compile class for JSP: 

An error occurred at line: [1] in the generated java file: [my_jsp.java]
The type java.util.Map$Entry cannot be resolved. It is indirectly referenced
from required .class files

Stacktrace:
   
org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:103)
   
org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:366)
    org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:477)
    org.apache.jasper.compiler.Compiler.compile(Compiler.java:379)
    org.apache.jasper.compiler.Compiler.compile(Compiler.java:354)
    org.apache.jasper.compiler.Compiler.compile(Compiler.java:341)
   
org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:657)
   
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:357)
    org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:395)
    org.apache.jasper.servlet.JspServlet.service(JspServlet.java:339)
    javax.servlet.http.HttpServlet.service(HttpServlet.java:727)

Even when doing the also recommended

<%@page import="java.util.Map" %><%@ page import="java.util.HashMap" %>

java -version
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message