tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: [VOTE] Release Apache Tomcat 8.0.14
Date Fri, 26 Sep 2014 20:58:20 GMT
On 26/09/2014 16:34, Christopher Schultz wrote:
> Mark,
> 
> On 9/26/14 3:55 AM, Mark Thomas wrote:
>> On 25/09/2014 20:56, Christopher Schultz wrote:
>>
>>> Some test fail. On my system the "tribes" tests always fail, likely due
>>> to missing multicast support
>>
>> Yes, that will trigger test failures.
> 
> I've never explicitly set up multicast, so I've always assumed that it's
> not configured. I have multiple Linux environments and an OS X laptop
> (where I've never bothered to run the full test-suite).
> 
> On Linux, eth0 says:
> 
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
> 
> So it seems like multicast should be enabled. Is there special
> configuration you know of that might be required in order to run those
> tests?
> 
> On my Mac, I see multicast as well for both en0 (disconnected ethernet)
> and en1 (connected wireless):
> 
> en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
> 
> Would additional configuration be required to run these tests on the Mac?

If I recall correctly, you have to disable the firewall on a Mac before
those tests will work.

Take a look at org.apache.catalina.tribes.TesterMulticast

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message