tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Time for 7.0.51
Date Fri, 07 Feb 2014 03:14:46 GMT
2014-02-05 Violeta Georgieva <violetagg@apache.org>:
> Hi,
>
> I want to start the release procedure for Tomcat 7.0.51.
> If you would like to add something to this release please respond to this
> mail.
>

Running testsuite BIO,NIO,APR on current 7.0.x (@ r1565513)
Win7,  Java 6u45 (+7u51) 32-bit.
(TC Native 1.1.29).

Two test classes are failing:

1) TEST-org.apache.tomcat.websocket.TestWebSocketFrameClient.NIO.txt
Testsuite: org.apache.tomcat.websocket.TestWebSocketFrameClient
Tests run: 2, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 45,553 sec

Testcase: testBug56032 took 24,121 sec
    FAILED
There are [1] connections still open
junit.framework.AssertionFailedError: There are [1] connections still open
    at org.apache.tomcat.websocket.TestWebSocketFrameClient.testBug56032(TestWebSocketFrameClient.java:164)

2) TEST-org.apache.catalina.core.TestAsyncContextImpl.APR.txt
Testsuite: org.apache.catalina.core.TestAsyncContextImpl
Tests run: 48, Failures: 17, Errors: 0, Skipped: 0, Time elapsed: 58,127 sec

Here 17 tests of 48 failed.
For example, a bunch of failures looks like this:
The actual duration is about 1000 (+/-5) ms, expected >= 2900.
---
Testcase: testTimeoutListenerCompleteAsyncDispatch took 1,725 sec
    FAILED
Uri: /start, Status: 200, Time: 1000 duration is not >= 2900
junit.framework.AssertionFailedError: Uri: /start, Status: 200, Time:
1000 duration is not >= 2900
    at org.apache.catalina.valves.TesterAccessLogValve.validateAccessLog(TesterAccessLogValve.java:81)
    at org.apache.catalina.core.TestAsyncContextImpl.doTestTimeout(TestAsyncContextImpl.java:523)
    at org.apache.catalina.core.TestAsyncContextImpl.testTimeoutListenerCompleteAsyncDispatch(TestAsyncContextImpl.java:414)
---

Some testcases here failed with wrong status (expected:<200> but
was:<500>), and wrong results (expected:<OK> but was:<null>).


My guess looking at this is that timeout handling in APR connector is broken.

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message