tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 55944] TLS v1.2 not working in Tomcat 6 and 7
Date Wed, 01 Jan 2014 17:46:16 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=55944

--- Comment #6 from Mudassir Aftab <withmudassir@gmail.com> ---
I am using following connector in Apache Tomcat/7.0.42

<Connector port="8443"
           protocol="HTTP/1.1"
           maxThreads="200"
           scheme="https" secure="true" SSLEnabled="true"
           SSLCertificateFile="/home/mudassir/pay/p.pem"
           SSLCertificateKeyFile="/home/mudassir/p/p-key.pem"
           sslEnabledProtocols="TLSv1.2"
           SSLCACertificateFile="/home/mudassir/p/AdminCA1.pem" />

An error occurred during a connection to confidential.com:8443. Cannot
communicate securely with peer: no common encryption algorithm(s). (Error code:
ssl_error_no_cypher_overlap)


CRITICAL - Cannot make SSL connection
140441642727072:error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert
handshake failure:s23_clnt.c:724:
HTTP CRITICAL - Error on receive
root@confidential:/opt/tomcat7#

I have tried 7.0.42 . 7.0.47 ,6.0.36 and 6.0.37 but nothing helped me yet. Can
you please help me on this ?

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message