tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Christoforides (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MTOMCAT-257) Classpathes separation between plugin and application is broken (can't use slf4j-jcl in app)
Date Wed, 22 Jan 2014 18:53:20 GMT

    [ https://issues.apache.org/jira/browse/MTOMCAT-257?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13879004#comment-13879004
] 

Andreas Christoforides commented on MTOMCAT-257:
------------------------------------------------

I am having a similar issue but with the Google Guava dependency (version 15.0). 

Setup:
* useSeparateTomcatClassLoader is enabled
* Google Guava version in dependency management is 15.0
* Using tomcat6:run

I was getting a NoSuchMethodException when using a Google Guava method that was added in version
15.0. I enabled the -verbose:class flag and I noticed that all the Google Guava classes for
my webapp were being loaded from version 10.0.1 instead of version 15.0.

The problem does NOT occur when running the WAR in a standalone Tomcat instance.

Google Guava version 10.0.1 is actually one of the dependencies of the Maven Tomcat plugin
itself. It seems that dependencies from the plugin are mixed with the webapp even if the setting
useSeparateTomcatClassLoader is enabled.

> Classpathes separation between plugin and application is broken (can't use slf4j-jcl
in app)
> --------------------------------------------------------------------------------------------
>
>                 Key: MTOMCAT-257
>                 URL: https://issues.apache.org/jira/browse/MTOMCAT-257
>             Project: Apache Tomcat Maven Plugin
>          Issue Type: Bug
>          Components: tomcat7
>    Affects Versions: 2.1
>            Reporter: Brendan Le Ny
>            Assignee: Olivier Lamy (*$^¨%`£)
>         Attachments: MTOMCAT-227-2.zip, MTOMCAT-227.tgz
>
>
> I use in my war the slf4j-jcl, which is not compatible with the jcl-over-slf4j used in
the plugin dependencies.
> I give you a little project that show the problem.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message