tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 55905] New: Error message unhelpful when web.xml references a tld file that doesn't exist
Date Wed, 18 Dec 2013 14:30:15 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=55905

            Bug ID: 55905
           Summary: Error message unhelpful when web.xml references a tld
                    file that doesn't exist
           Product: Tomcat 7
           Version: 7.0.47
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Catalina
          Assignee: dev@tomcat.apache.org
          Reporter: anthonygerrard+apache.org@gmail.com

In your web-application web.xml add a taglib element but get the
taglib-location wrong or forgot to include *.tld when packaging your archive

  <jsp-config>
    <taglib>
        <taglib-uri>http://www.example.org/mytaglib</taglib-uri>
        <taglib-location>/WEB-INF/wrong.tld</taglib-location>
    </taglib>
  </jsp-config>

Start you web-app.

Expected:

Get a helpful message like

WARN  org.apache.catalina.startup.TldConfig - Failed to process TLD with path
[/WEB-INF/wrong.tld] and URI [http://www.example.org/mytaglib]
java.io.FileNotFoundException: /WEB-INF/wrong.tld
...

Actual:

WARN  org.apache.catalina.startup.TldConfig - Failed to process TLD with path
[http://www.example.org/mytaglib] and URI [/WEB-INF/wrong.tld]
java.net.MalformedURLException: null
...

Note also that with the current error message the path is labelled at the URI
and vice versa, adding to the confusion.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message