tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy (*$^¨%`£) (JIRA) <j...@apache.org>
Subject [jira] [Closed] (MTOMCAT-75) Dependency scope of "tomcat" needed for addContextWarDependencies to work in run/run-war goals.
Date Mon, 04 Nov 2013 04:14:20 GMT

     [ https://issues.apache.org/jira/browse/MTOMCAT-75?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Olivier Lamy (*$^¨%`£) closed MTOMCAT-75.
-----------------------------------------

    Resolution: Duplicate
      Assignee: Olivier Lamy (*$^¨%`£)

> Dependency scope of "tomcat" needed for addContextWarDependencies to work in run/run-war
goals.
> -----------------------------------------------------------------------------------------------
>
>                 Key: MTOMCAT-75
>                 URL: https://issues.apache.org/jira/browse/MTOMCAT-75
>             Project: Apache Tomcat Maven Plugin
>          Issue Type: Improvement
>    Affects Versions: 1.1
>         Environment: Apache Maven 3.0 (r1004208; 2010-10-04 07:50:56-0400)
> Java version: 1.6.0_22
> Java home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
> Default locale: en_US, platform encoding: MacRoman
> OS name: "mac os x" version: "10.5.8" arch: "x86_64" Family: "mac"
>            Reporter: Ryan Connolly
>            Assignee: Olivier Lamy (*$^¨%`£)
>
> The feature to deploy dependency wars to embedded containers created with tomcat:run
and tomcat:run-war depend upon a war dependency scope being defined as "tomcat".  It would
seem a much cleaner to allow the configuration of such war dependencies in the plugin dependencies
using a valid dependency scope.
> Log Output:
> [WARNING] Some problems were encountered while building the effective model for com.rynam0:tomcat-maven-plugin-test:war:1.0-SNAPSHOT
> [WARNING] 'dependencies.dependency.scope' for com.rynam0:simple-portal-war:war must be
one of [provided, compile, runtime, test, system] but is 'tomcat'. @ line 22, column 14
> [WARNING] 
> [WARNING] It is highly recommended to fix these problems because they threaten the stability
of your build.
> [WARNING] 
> [WARNING] For this reason, future Maven versions might no longer support building such
malformed projects.
> [WARNING] 



--
This message was sent by Atlassian JIRA
(v6.1#6144)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message