tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Preißer <kpreis...@apache.org>
Subject RE: [Tomcat 8.0.x trunk] APR sendfile problem
Date Sat, 12 Oct 2013 22:27:11 GMT


> -----Original Message-----
> From: Ognjen Blagojevic [mailto:ognjen.d.blagojevic@gmail.com]
> Sent: Sunday, October 13, 2013 12:11 AM
> To: Tomcat Developers List
> Subject: Re: [Tomcat 8.0.x trunk] APR sendfile problem
> 
> Konstantin,
> 
> On 12.10.2013 3:52, Konstantin Preißer wrote:
> > I also tried this now with trunk (r1531312) and Native 1.1.29 RC on Windows
> 8 64-bit with Java 1.7.0_40, and can confirm the behavior:
> > With the above configuration for a SSL HTTP APR connector, I cannot
> receive the contents of "/docs/manager-howto.html", whereas it works if I
> either add useSendfile="true" or useSendfile="false".
> 
> Thank you for verifying.
> 
> I now re-read the docs, and realized that sendfile is not allowed with
> HTTPS, so one should always add useSendfile="false" to HTTPS APR
> connector.
> 
> It is strange that useSendfile="true", and not adding attribute
> useSendfile at all behaves differently, but this is, IMO, minor issue in
> interpreting server.xml.

BTW, if I revert the changes in r1530269 (in AprEndpoint) then that specific issue does no
longer appear when "useSendfile" attribute is not specified on the SSL connector - then Firefox
shows the correct contents if I request "/docs/manager-howto.html".


Regards,
Konstantin Preißer


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message