tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeanfrancois Arcand <jfarcand....@gmail.com>
Subject Re: [VOTE] Release Apache Tomcat 7.0.43
Date Fri, 20 Sep 2013 10:57:40 GMT

On 2013-09-20 6:26 AM, Mark Thomas wrote:
> On 20/09/2013 11:24, Jeanfrancois Arcand wrote:
>> Hi,
>>
>> [X] Broken - do not release
>>
>> I do test/use Tomcat with WebSocket since 7.0.27. 8.0.0-RC1 worked well
>> with jsr356, but 7.0.43 is broken. You can try it by deploying
>>
>> http://search.maven.org/remotecontent?filepath=org/atmosphere/samples/atmosphere-chat/2.0.0/atmosphere-chat-2.0.0.war
> Just a quick question, were you running on Java 7?
Ah! No I wasn't. I think a log message or warning should be written 
because the jsr356's ServerApplicationConfig is scanned and created with 
jdk 6, hence initialized.

So I confirm it works with jdk7, with a small error

    https://gist.github.com/jfarcand/6635844

I don't get that error with 8.0.0-RC3 (will file an issue). But that 
shouldn't stop the release, so  I change my vote to

[X] Stable - go ahead and release as 7.0.43 Stable

(native and jsr 356 websockets works fine)

Thanks

-- Jeanfrancois





>
> Mark
>
>
>>
>> This application will works fine with GlassFish 4, Jetty 9.1.0 and
>> Tomcat 8.0.0-RC1, but not with 7.0.43. It seems the websocket's url is
>> not detected by Tomcat, hence requests are failing with
>>
>> ebSocket connection to
>> 'ws://127.0.0.1:8080/atmosphere-chat/chat?X-Atmosphere-tracking-id=0&X-Atmosphere-Framework=2.0.3-javascript&X-Atmosphere-Transport=websocket&X-Atmosphere-TrackMessageSize=true&X-Cache-Date=0&Content-Type=application/json&X-atmo-protocol=true'
>> failed: Unexpected response code: 200
>>
>> Thanks
>>
>> -- Jeanfrancois
>>
>>
>>
>> On 2013-09-20 3:38 AM, Violeta Georgieva wrote:
>>> The proposed Apache Tomcat 7.0.43 release is now available for voting.
>>> This release candidate contains JSR-356 Java WebSocket 1.0
>>> implementation.
>>> Note that use of this functionality requires Java 7.
>>>
>>> It can be obtained from:
>>> https://dist.apache.org/repos/dist/dev/tomcat/tomcat-7/v7.0.43/
>>> The Maven staging repo is:
>>> https://repository.apache.org/content/repositories/orgapachetomcat-082/
>>> The svn tag is:
>>> http://svn.apache.org/repos/asf/tomcat/tc7.0.x/tags/TOMCAT_7_0_43/
>>>
>>> The proposed 7.0.43 release is:
>>> [ ] Broken - do not release
>>> [ ] Stable - go ahead and release as 7.0.43 Stable
>>>
>>> Regards
>>> Violeta
>>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: dev-help@tomcat.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message