tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 55177] New: connectionTimeout=-1 causes high CPU
Date Mon, 01 Jul 2013 19:49:21 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=55177

            Bug ID: 55177
           Summary: connectionTimeout=-1 causes high CPU
           Product: Tomcat 7
           Version: trunk
          Hardware: PC
                OS: Mac OS X 10.4
            Status: NEW
          Severity: minor
          Priority: P2
         Component: Connectors
          Assignee: dev@tomcat.apache.org
          Reporter: thrain123@gmail.com

Created attachment 30514
  --> https://issues.apache.org/bugzilla/attachment.cgi?id=30514&action=edit
fix

Setting connectionTimeout to -1 in server.xml causes each request to have high
CPU 

java full version "1.6.0_51-b11-457"
Example:
<Connector port="8080" protocol="HTTP/1.1"
               connectionTimeout="-1"
               redirectPort="8443" />

Everywhere I looked there seemed to be a if statement looking to see if it was
below zero except in Http11Processor class. Attached is patch file. Which has
resolved the issue on my server.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message