tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrii Rubtsov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MTOMCAT-178) additionalClasspathDirs doesn't seem to be used
Date Mon, 22 Jul 2013 13:00:49 GMT

    [ https://issues.apache.org/jira/browse/MTOMCAT-178?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13715182#comment-13715182
] 

Andrii Rubtsov commented on MTOMCAT-178:
----------------------------------------

Any update on this, guys? As far far as I can see, it does not indeed seem to be used.
                
> additionalClasspathDirs doesn't seem to be used
> -----------------------------------------------
>
>                 Key: MTOMCAT-178
>                 URL: https://issues.apache.org/jira/browse/MTOMCAT-178
>             Project: Apache Tomcat Maven Plugin
>          Issue Type: Bug
>          Components: tomcat7
>    Affects Versions: 2.0
>         Environment: Maven 3.0.3 / Linux / OpenJDK 7
>            Reporter: Craig
>            Assignee: Olivier Lamy (*$^¨%`£)
>
> Using the plugin like this:
>                         <plugin>
>                             <groupId>org.apache.tomcat.maven</groupId>
>                             <artifactId>tomcat7-maven-plugin</artifactId>
>                             <version>2.0</version>
>                             <configuration>
>                                 <additionalClasspathDirs>
>                                     <additionalClasspathDir>${project.build.directory}/../../../mits-common-parent/common-ui/src/main/resource$
>                                     <additionalClasspathDir>${project.build.directory}/../src/main/webapp</additionalClasspathDir>
>                                 </additionalClasspathDirs>
>                             </configuration>
>                         </plugin>
> I run Tomcat like this:
> mvn tomcat7:run
> The application starts and runs fine. But, when the classloader loads a resource that
is in one of the additionalClasspathDir entries, it loads it from the .war, not from the additionalClasspathDir
location. Nothing I do seems to make Tomcat use the additionalClasspathDir entries.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message