tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Williams <nicho...@nicholaswilliams.net>
Subject Re: Java 7 support on Tomcat 5.5
Date Mon, 01 Apr 2013 20:58:19 GMT

On Apr 1, 2013, at 3:44 PM, Satheesh Babu wrote:

> Good Evening!
> 
> We're running our production applications in Tomcat 5.5/JRE 1.5, and there is a need
for us to migrate our applications to Java 7(JRE 1.7). There is no information available either
on java or on Apace Tomcat site regrading the compatibility of java 7 with tomcat 5.5. Could
you please let me know the compatibility of Java 7/Tomcat 5.5 (or) do we need to upgrade tomcat
to 6 (or) 7, for java 7.
> 
> I truly appreciate your response, thanks for your timely help.
> 
> Thanks,
> Satheesh Babu


First, this is the wrong list for such a question. This question belongs on the User's list.
I am cross-posting on both lists this one time to inform you of this and to relocate the topic.

Second, good to hear that your organization is making the jump to Java 7. Java 6 is no longer
supported and Java 8 will be out soon.

Third, upgrade Tomcat. Tomcat 5.5 is extremely old and no longer supported. That's why you
won't even find it on the Tomcat site proper [1] anymore, you can only find it in the archives.
You will likely not find anyone on these lists willing to help you much with 5.5.

Finally, Tomcat 6 and 7 will both run quite fine on Java 7, but they will not compile on Java
7. If you want a version of Tomcat that compiles on Java 7, you will need to wait for Tomcat
8, which is currently in development and should (hopefully) be out later this year.

[1] http://tomcat.apache.org/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message