tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 54559] [PATCH] 1.1.27 needs APR >= 1.3.0
Date Fri, 15 Feb 2013 04:28:11 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=54559

Rainer Jung <rainer.jung@kippdata.de> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REOPENED                    |RESOLVED
         Resolution|---                         |FIXED

--- Comment #5 from Rainer Jung <rainer.jung@kippdata.de> ---
- reverted the original patch
- added a configure warning about 1.2.0 for better performance when 1.2.0 is
used
- added another changelog entry
- added your 1.2.0 compat patch

Note taken from mail on dev list:

The APR version check in jnilib.c wouldn't detect whether a build was
done against 1.3.x and at runtime there's only 1.2.x. I don't know
whether that leads to missing symbols or other problems. I refrained
from writing the configure time apr version to a generated header file
and then use that version during the runtime test: On Unix/Linux that
should not happen because of the SONAME rules used by APR libs. Don't
know whether the same is true for Windows. If "yes", then we don't have
a problem, but I then don't understand the necessity for the runtime APR
version check in jnilib.c 

Regards,

Rainer

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message