tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 53871] java.lang.StackOverflowError on deploying a web application
Date Fri, 01 Feb 2013 20:29:06 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=53871

--- Comment #11 from John Bize <John.Bize@ExceptionalSoftware.com> ---
(In reply to comment #10)

Thanks for your reply, and thanks for all the volunteer efforts on this
project.  It is appreciated, and I didn't mean to imply otherwise.

I do believe I have the same problem.  When starting up 7.0.29 and deploying
two WARs, one of my WARs fails to deploy with a very similar stack trace.  (I'm
in deployWARs instead of deployDescriptors, but I think that must be due to a
different version than the original post.  Other than that and the HashMap vs.
HashSet, the stacks are pretty much the same.)  My stack ends with the
following:

...
Caused by: java.lang.StackOverflowError at
java.util.HashMap.get(HashMap.java:300) at
org.apache.catalina.startup.ContextConfig.populateSCIsForCacheEntry(ContextConfig.java:2215)
at
org.apache.catalina.startup.ContextConfig.populateSCIsForCacheEntry(ContextConfig.java:2227)
at ...

There are 1024 recursions at line 2227 before the stack is exhausted.  I'm not
able to set -Xss large enough to make any difference. The
populateSCIsForCacheEntry always recurses 1024 times and throws the
StackOverflowError Error.  That seems like a very deep recursion.  The fact
that different deploy paths (<Host appBase=...) can change the behavior doesn't
make sense either.

It isn't fixed for me, but I will try to find another resolution.  

Thanks again.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message