tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Boynes <jboy...@apache.org>
Subject [taglibs] TCK update
Date Sat, 02 Feb 2013 18:37:06 GMT
On Jan 29, 2013, at 11:56 PM, Jeremy Boynes wrote:
> On Jan 28, 2013, at 3:46 AM, Mark Thomas wrote:
> On 26/01/2013 21:51, Henri Yandell wrote:
...
>> 
>> I've just checked the latest version of the TCK documentation for JSTL
>> 1.2 and while the TCK has been updated so it will run on Java 7, the
>> reference runtime remains Java 5. My interpretation of that is that the
>> TCK must pass when running with a Java 5 JRE.
> 
> My interpretation was that a product must pass the TCK in all its configurations. In
other words, you can't claim compatibility on Java7 unless you've tested on Java7. If we test
on Java7 and pass, we can claim we're a compatible implementation in that mode; if we don't
test on Java5 then we can't claim compatibility on Java5 but that does not stop us being compatible
on Java7. I read it as being sufficient if we document what we require as a resource.
> 
> @Henri, I ran all tests on Java6 and have not tried SQL on Java7. I'll pull the newer
version and retest.

The newer TCK does not have some of the scripts that were in the older one so I think the
instructions on running it may have changed. The release notes say the User Guide is packaged
separately from the TCK download. Mark, please could you check for any other updates related
to this TCK.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message