tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rj...@apache.org
Subject svn commit: r1449753 - in /tomcat/native/branches/1.1.x: native/build/tcnative.m4 native/src/jnilib.c xdocs/miscellaneous/changelog.xml
Date Mon, 25 Feb 2013 15:40:09 GMT
Author: rjung
Date: Mon Feb 25 15:40:08 2013
New Revision: 1449753

URL: http://svn.apache.org/r1449753
Log:
Followup on r1446443: compatibility version
is APR 1.2.1 not 1.2.0.

That's how it was before r1445989 (1.3.0
dependency).

APR 1.2.0 was not released, so it actually
makes no difference except someone would
try to use a non-released version.

Modified:
    tomcat/native/branches/1.1.x/native/build/tcnative.m4
    tomcat/native/branches/1.1.x/native/src/jnilib.c
    tomcat/native/branches/1.1.x/xdocs/miscellaneous/changelog.xml

Modified: tomcat/native/branches/1.1.x/native/build/tcnative.m4
URL: http://svn.apache.org/viewvc/tomcat/native/branches/1.1.x/native/build/tcnative.m4?rev=1449753&r1=1449752&r2=1449753&view=diff
==============================================================================
--- tomcat/native/branches/1.1.x/native/build/tcnative.m4 (original)
+++ tomcat/native/branches/1.1.x/native/build/tcnative.m4 Mon Feb 25 15:40:08 2013
@@ -33,10 +33,10 @@ AC_DEFUN(TCN_FIND_APR,[
   sapr_version="`echo $sapr_pversion|sed -e 's/\([a-z]*\)$/.\1/'`"
   tc_save_IFS=$IFS; IFS=.; set $sapr_version; IFS=$tc_save_IFS
   if test "${1}" -lt "1"; then
-    AC_MSG_ERROR(You need APR version 1.2.0 or newer installed. For optimal performance version
1.3.0 or newer is needed.)
+    AC_MSG_ERROR(You need APR version 1.2.1 or newer installed. For optimal performance version
1.3.0 or newer is needed.)
   else
     if test "${2}" -lt "2"; then
-      AC_MSG_ERROR(You need APR version 1.2.0 or newer installed. For optimal performance
version 1.3.0 or newer is needed.)
+      AC_MSG_ERROR(You need APR version 1.2.1 or newer installed. For optimal performance
version 1.3.0 or newer is needed.)
     elif test "${2}" -lt "3"; then
       AC_MSG_WARN(For optimal performance you need APR version 1.3.0 or newer installed.)
     fi

Modified: tomcat/native/branches/1.1.x/native/src/jnilib.c
URL: http://svn.apache.org/viewvc/tomcat/native/branches/1.1.x/native/src/jnilib.c?rev=1449753&r1=1449752&r2=1449753&view=diff
==============================================================================
--- tomcat/native/branches/1.1.x/native/src/jnilib.c (original)
+++ tomcat/native/branches/1.1.x/native/src/jnilib.c Mon Feb 25 15:40:08 2013
@@ -63,7 +63,7 @@ JNIEXPORT jint JNICALL JNI_OnLoad(JavaVM
      */
     apr_version(&apv);
     apvn = apv.major * 1000 + apv.minor * 100 + apv.patch;
-    if (apvn < 1200) {
+    if (apvn < 1201) {
         tcn_Throw(env, "Unupported APR version (%s)",
                   apr_version_string());
         return JNI_ERR;

Modified: tomcat/native/branches/1.1.x/xdocs/miscellaneous/changelog.xml
URL: http://svn.apache.org/viewvc/tomcat/native/branches/1.1.x/xdocs/miscellaneous/changelog.xml?rev=1449753&r1=1449752&r2=1449753&view=diff
==============================================================================
--- tomcat/native/branches/1.1.x/xdocs/miscellaneous/changelog.xml (original)
+++ tomcat/native/branches/1.1.x/xdocs/miscellaneous/changelog.xml Mon Feb 25 15:40:08 2013
@@ -43,7 +43,7 @@
       from Tomcat trunk using svn:externals. (rjung)
     </update>
     <update>
-      Minimum supported APR version is now again 1.2.0. Version 1.3.0
+      Minimum supported APR version is now again 1.2.1. Version 1.3.0
       of APR improves performance. (rjung)
     </update>
   </changelog>



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message