tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy (*$^¨%`£) (JIRA) <j...@apache.org>
Subject [jira] [Closed] (MTOMCAT-185) change phase for tomcat6/7:run to process-classes
Date Mon, 07 Jan 2013 21:50:14 GMT

     [ https://issues.apache.org/jira/browse/MTOMCAT-185?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Olivier Lamy (*$^¨%`£) closed MTOMCAT-185.
------------------------------------------

    Resolution: Fixed

no idea why the issue was reopened.
                
> change phase for tomcat6/7:run to process-classes
> -------------------------------------------------
>
>                 Key: MTOMCAT-185
>                 URL: https://issues.apache.org/jira/browse/MTOMCAT-185
>             Project: Apache Tomcat Maven Plugin
>          Issue Type: Bug
>          Components: tomcat7
>    Affects Versions: 2.0
>            Reporter: Jiri Peinlich
>            Assignee: Olivier Lamy (*$^¨%`£)
>              Labels: maven, newbie
>             Fix For: 2.1
>
>
> Hello, 
> I do not know enough about maven+tomcat and related technologies to know if the following
is bug, or if I just missed some setting somewhere. 
> We have in our project dependencies, that inject some byte-code into compiled classes
in the process-classes maven phase. I was trying to use maven  tomcat7 plugin in version 2.0
to see how is our application working. When executing mvn tomcat7:run i run into problems
because the maven phase process-classes was not executed before deploying on tomcat. 
> After some research we found that there is plugin.xml file in the tomcat7 plugin jar
that maven downloads (org.apache.tomcat.maven.tomcat7-maven-plugin) (META_INF/maven/plugin.xml).
In this file i found mojo with <goal>run</goal> and in this mojo there i found
<executePhase>compile</executePhase>. I think that the execution phase should
be set to process-classes phase and not compile phase.
> My problems disappeared When I manually edited the xml and tried the mvn tomcat7:run
afterwards. This makes me think that the phase is wrongly set in the jar. 
> I checked the sources and to me it seams that the phase should be set here:
> http://svn.apache.org/viewvc/tomcat/maven-plugin/trunk/tomcat7-maven-plugin/src/main/java/org/apache/tomcat/maven/plugin/tomcat7/run/RunMojo.java?view=markup
> The execution phase is set there to be compile (curretnly line 60)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message