tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Gooding <josh.good...@gmail.com>
Subject Re: auto-undeploy Old Context patch
Date Sun, 09 Dec 2012 12:51:39 GMT
On Sat, Dec 8, 2012 at 9:59 PM, Konstantin Kolinko
<knst.kolinko@gmail.com>wrote:

> 2012/12/9 Josh Gooding <josh.gooding@gmail.com>:
> > Sounds good.  I grabbed the source and have it imported into Eclipse.
>  If I
> > can ask here:
> >
>
> Do not top-post
> http://en.wikipedia.org/wiki/Posting_style
>

Oh sorry about that, I'll try to remember that in the future.

>
> > I'm developing on a Win-x64 Environment using JDK 1.6.0_34.  I am
> following
> > along with the BUILDING.txt file and have taken the default
> > build.properties.default and used it to create a standard
> build.properties
> > file.  I have the parameter: base.path=C:/Users/Josh/workspace/TC7 set
> > where the trunk is checked out to.
>
> It is a bas idea. It is better to point it to some empty directory. It
> is where the libraries will be downloaded.
>
> > I run the build.xml from my IDE and I get 15 compile errors from the
> > \tomcat7-deps\dbcp\src\java\org\apache\tomcat\dbcp\dbcp\ package.  The
> > firsts compiler error I get (just as an example) is:
> >
> > BasicDataSource is not abstract and does not override abstract method
> > getParentLogger() in CommonDataSource
> >
> > Any clues to what would cause this?  Since I haven't gotten the project
> off
> > the ground and building yet, I'm just curious if it could be my setup or
> if
> > there is some other underlying issue.
>
> DBCP cannot be compiled with Java 7, because of new methods in JDBC
> classes that it implements.  I'd say that your Ant build is using JDK
> 7 instead of that 1.6.0_34.
>

Seemes to be the issue(s) I was having.  Ok, I am looking at your bugzilla
log.  Thanks Konstantin for getting me all

Warmest Regards,

Josh

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message