tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arne Franken (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MTOMCAT-173) Direct dependencies are not added to classpath
Date Wed, 14 Nov 2012 15:58:12 GMT

    [ https://issues.apache.org/jira/browse/MTOMCAT-173?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13497175#comment-13497175
] 

Arne Franken commented on MTOMCAT-173:
--------------------------------------

I just built 2.1-SNAPSHOT locally and can confirm that the issue is fixed. Thanks!
                
> Direct dependencies are not added to classpath
> ----------------------------------------------
>
>                 Key: MTOMCAT-173
>                 URL: https://issues.apache.org/jira/browse/MTOMCAT-173
>             Project: Apache Tomcat Maven Plugin
>          Issue Type: Bug
>          Components: tomcat6, tomcat7
>    Affects Versions: 2.0
>            Reporter: Arne Franken
>            Assignee: Olivier Lamy (*$^¨%`£)
>             Fix For: 2.1
>
>
> in DefaultClassLoaderEntriesCalculator#calculateClassPathEntries, direct dependencies
are not added, the log message says "skip adding artifact " + artifact.getArtifactId() + "
as it's in reactors". 
> In my case, it's a jar that is configured as a direct dependency. When the Webapp starts,
the Jar is missing from the Classpath and the startup fails.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message