tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 53719] New: Path in /META-INF/Context.xml not getting used
Date Tue, 14 Aug 2012 15:49:28 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=53719

          Priority: P2
            Bug ID: 53719
          Assignee: dev@tomcat.apache.org
           Summary: Path in /META-INF/Context.xml not getting used
          Severity: major
    Classification: Unclassified
          Reporter: patrick.barry@cnoinc.com
          Hardware: Macintosh
            Status: NEW
           Version: 7.0.29
         Component: Catalina
           Product: Tomcat 7

I am trying to set the context root of our webapp, to be "myapp", however, the
name of the war file dropped into the webapps directory, is myapp-1.0.4.war.  I
read that if I provided a context.xml file under /META-INF of my war, then I
could specify the path and that should be used instead of the war name.
However, that is not happening.  I have tried with Tomcat's base install, and
then I also set deployXML="true" as well as copyXML="true" on the host as well.
None of it had an impact. 

my context.xml..
<Context path="/myapp" docBase="webapps/myapp-1.0.4.war"/> 

I also tried:
<Context path="/myapp" docBase="webapps/myapp-1.0.4"/>

When I drop myapp-1.0.4.war into /webapps, it is deployed, however I have to
acces it via localhost:8080/myapp-1.0.4

After deployment, I see /conf/Catalina/localhost/who-1.0.4.xml get created.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message