tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: tcnative version check broken for test suite of TC 7
Date Sun, 17 Jun 2012 10:20:26 GMT
2012/6/16 Rainer Jung <rainer.jung@kippdata.de>:
> I accidentially ran the tc 7.0.28 test suite with tcnative 1.1.23. It
> crashes. Required version of tcnative is now 1.1.24.
>
> It seems the handling of a version mismatch in the AprLifecycleListener
> isn't sufficient to prevent running TC with apr connector, at least not for
> the test suite.

The same happens when you explicitly select the "Apr" protocol variant
in server.xml.

I created a bug report for it:
https://issues.apache.org/bugzilla/show_bug.cgi?id=53430

>From what I can see, this is an old issue.

I think we have to add some emphasis to the Tomcat-Native version bump
in the release announcement for 7.0.28.

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message