tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <cos...@gmail.com>
Subject Re: native connector tool chain
Date Mon, 21 May 2012 17:35:46 GMT
On Mon, May 21, 2012 at 10:31 AM, Mark Thomas <markt@apache.org> wrote:

> On 21/05/2012 17:52, Mladen Turk wrote:
> > On 05/21/2012 02:05 PM, Mark Thomas wrote:
> >> I am trying to build the 1.1.x native connector from trunk so I can test
> >> the changes I plan to make to support per socket time outs. I can build
> >> using dynamic linking but not statically. What tool chain are folks
> >> currently using to build the native connector binaries we currently
> ship?
> >>
> >> My current issue relates to statically linking to OpenSSL. I get the
> >> same failure with 1.0.c, 0.9.8x and 0.9.8k. I am using:
> >> - Visual Studio 6 + SP6
> >> - Win 2003 r2 Platform SDK
> >> - OpenSSL binaries from http://slproweb.com/products/Win32OpenSSL.html
> >
> > If those binaries were not compiled with VS6 you can't statically link
> > them. When I build binaries I build both of those (and apr) with the
> > same compiler.
> >
> > Yeah, it's not trivial task.
>
> :). Thanks. That explains what is going on. I might look into building
> OpenSSL with Visual Studio 6 if I get a spare week and a desire to make
> my brain hurt :)
>

I think chrome has some build files for openssl similar with cmake, i.e.
one config that can generate visual studio, eclipse, makefile, etc.

My brain hurts whenever I touch autoconfig, I suppose the pain with VS6 is
similar.

Costin


> Mark
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: dev-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message