tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 53088] New: Give PoolCleaner TimerTask a better name
Date Tue, 17 Apr 2012 07:30:25 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=53088

             Bug #: 53088
           Summary: Give PoolCleaner TimerTask a better name
           Product: Tomcat Modules
           Version: unspecified
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: minor
          Priority: P2
         Component: jdbc-pool
        AssignedTo: dev@tomcat.apache.org
        ReportedBy: 1983-01-06@gmx.net
    Classification: Unclassified


Currently, the TimerTask has the thread name "PoolCleaner[<number>:<number>]".
This is not really helpful (I was not able to identify this therad with
VisualVM at first glance) and can be messed with Oracle JNDI PoolCleaner.

A clearer name would help a lot. Since this thread is a singleton, I do not
seed any need to display classloader id and startup time. I have attached a
patched against with a proposal for a better name.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message